Bug 615750 - [abrt] crash in compiz-0.8.6-1.fc13: memcpy: Process /usr/bin/compiz was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in compiz-0.8.6-1.fc13: memcpy: Process /usr/bin/compiz was kill...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tk (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ceb9e59493e636a93654cca38f6...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-18 12:49 UTC by Peque
Modified: 2010-08-05 23:38 UTC (History)
3 users (show)

Fixed In Version: tk-8.5.8-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 23:38:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (42.07 KB, text/plain)
2010-07-18 12:50 UTC, Peque
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenCompositing.org 1293 None None None Never
Gentoo 313285 None None None Never
Launchpad 579112 None None None Never

Description Peque 2010-07-18 12:49:56 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: compiz --ignore-desktop-hints glib gconf gnomecompat
component: compiz
crash_function: memcpy
executable: /usr/bin/compiz
global_uuid: ceb9e59493e636a93654cca38f6ba66b5e7e5c39
kernel: 2.6.33.6-147.fc13.x86_64
package: compiz-0.8.6-1.fc13
rating: 4
reason: Process /usr/bin/compiz was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
When I launched 'gitk --all' (to display a git project history), the Cairo-Dock (no OpenGl mode) crashed and the Cairo-Dock config window opened. I just closed this window (didn't restarted Cairo-Dock process).

After a minute working with gitk window opened (and doing anything else, I think), Compiz crashed and I lost all the window borders. I had to restart Compiz.

Comment 1 Peque 2010-07-18 12:50:01 UTC
Created attachment 432698 [details]
File: backtrace

Comment 2 Aaron Faanes 2010-07-22 04:06:52 UTC
Compiz crashes on alt-tab if gitk is open.

== Product versions ==
Fedora 13, updates-testing

compiz-0.8.6-1.fc13.x86_64
gitk-1.7.1.1-1.fc13.noarch

== How reproducible ==

100% on my machine.

== Prerequisites ==

* Run with Compiz enabled
* Have a git repository

== Steps to reproduce ==

1. open gitk
2. alt-tab
3. Crash!

== Workarounds ==

Note that successfully replicating this bug will make you unable to alt-tab or switch programs. You are able to access the gnome panels. Here's how to get an operational system again:

1. Go to 'System' > 'Preferences' > 'Desktop Effects' in the top panel.
2. Toggle to Standard, then back to Compiz. Things should be normal again.

== Additional info ==

This bug appears to be specific with gitk, as far as I know. It's also somewhat recently updated:

Jul 07 18:28:34 Updated: gitk-1.7.1.1-1.fc13.noarch

Comment 3 Aaron Faanes 2010-07-22 04:13:25 UTC
It looks like this has been fixed in an upstream commit. See this discussion:

http://comments.gmane.org/gmane.comp.video.opengl.compiz-fusion.devel/749

And the corresponding commit referenced in that discussion:

http://git.compiz.org/compiz/core/commit/?h=compiz-0.8&id=1bed3dbcea6473f84745ec7a1f936c4f5d3b3a01

Comment 4 Aaron Faanes 2010-07-22 05:07:02 UTC
This is very likely not a gitk bug. I ran gitk from git v1.6.5 (October 2009) and this error happened just as always. I also looked through the commits for gitk and didn't find anything suspicious (though I'm certainly no expert).

It should be noted that gitk and git-gui both don't have icons shown. Unless I'm very mistaken, I think both applications used to have icons.

Concluding from the above, this might be a tcl-tk related bug, especially since tcl-tk was updated on Sat 10 Jul 2010.

Here's the full version: tcl-8.5.8-1.fc13.x86_64

Comment 5 Aaron Faanes 2010-07-22 05:50:10 UTC
Very very likely to be a tcl-tk bug. 'yum downgrade tcl tk' fixes the crash issue and causes the icons for both gitk and git-gui to appear once again.

Here's the upgrade that broke us:

https://admin.fedoraproject.org/updates/tk-8.5.8-1.fc13,tcl-8.5.8-1.fc13

== Affected versions ==

tcl-8.5.8-1.fc13.x86_64
tk-8.5.8-1.fc13.x86_64

== Last known working versions ==

tcl-8.5.7-5.fc13.x86_64
tk-8.5.7-3.fc12.x86_64

Comment 6 Aaron Faanes 2010-07-22 07:19:18 UTC
It looks like this bug was found and fixed in upstream tk after the 8.5.8 release:

https://sourceforge.net/tracker/?func=detail&aid=2902814&group_id=12997&atid=112997

Here's the commit that fixes us:

http://tktoolkit.cvs.sourceforge.net/viewvc/tktoolkit/tk/unix/tkUnixWm.c?r1=1.58.2.3&r2=1.58.2.4

In summary, I think this is what happened: Tk's 'wm iconphoto' was broken in 8.5.8 (due to some endianness/64-bit weirdness that is beyond me). This breakage causes the icon to have an absurd size. wm iconphoto is used by gitk, so gitk ends up with a malformed icon. Compiz tries to use this malformed icon, and since it didn't check for bad sizes, it crashes.

So there's two bugs: Compiz ensuring it doesn't crash on invalid icon sizes, and Tk ensuring its data is in the form expected by X. Both of these problems appear to have been fixed in upstream.

Comment 7 Fedora Update System 2010-07-25 09:39:01 UTC
tk-8.5.8-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/tk-8.5.8-2.fc13

Comment 8 Jaroslav Škarvada 2010-07-25 09:40:19 UTC
Thank you for excellent bug report with resolution. Patched version
(tk-8.5.8-2.fc13) was pushed through bodhi, please test it.

Comment 9 Aaron Faanes 2010-07-25 23:22:29 UTC
I just successfully ran this update from koji. The missing icon issues for gitk and git-gui are fixed, and alt-tabbing with compiz works just fine.

I'm marking it as VERIFIED, but please change this back if this change is premature.

Comment 10 Fedora Update System 2010-07-27 02:54:40 UTC
tk-8.5.8-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tk-8.5.8-2.fc13

Comment 11 Fedora Update System 2010-08-05 23:38:46 UTC
tk-8.5.8-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.