Bug 615800 - SELinux is preventing /usr/libexec/gdm-session-worker "read append" access on .xsession-errors.
SELinux is preventing /usr/libexec/gdm-session-worker "read append" access on...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:7293dd62ec0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-18 18:22 EDT by Michal Pomorski
Modified: 2010-10-04 01:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 06:31:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Pomorski 2010-07-18 18:22:01 EDT
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "read append" access on
.xsession-errors.

Detailed Description:

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:home_root_t:s0
Target Objects                .xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.1-24.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-41.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.5-127.fc12.i686 #1 SMP Sat
                              Nov 7 21:41:45 EST 2009 i686 i686
Alert Count                   1
First Seen                    Mon 05 Apr 2010 08:17:52 PM CEST
Last Seen                     Mon 05 Apr 2010 08:17:52 PM CEST
Local ID                      548fff7d-3e21-4ebc-baef-a9a4d589acbf
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1270491472.673:41031): avc:  denied  { read append } for  pid=1568 comm="gdm-session-wor" name=".xsession-errors" dev=dm-1 ino=1828240 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:home_root_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1270491472.673:41031): arch=40000003 syscall=5 success=no exit=-13 a0=9736b70 a1=442 a2=180 a3=9736b70 items=0 ppid=1532 pid=1568 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,home_root_t,file,read,append
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t home_root_t:file { read append };
Comment 1 Miroslav Grepl 2010-07-19 06:31:29 EDT
It looks like your /home dir is mislabeled. Execute

restorecon -R -v /home

Also please update selinux-policy

yum update selinux-policy-targeted

Note You need to log in before you can comment on or make changes to this bug.