Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 615880 - luci dies with error 500 importing cluster.conf with unknown/unsupported fence agents
luci dies with error 500 importing cluster.conf with unknown/unsupported fenc...
Status: CLOSED DUPLICATE of bug 613871
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 04:11 EDT by Fabio Massimo Di Nitto
Modified: 2010-07-26 10:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 10:21:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2010-07-19 04:11:26 EDT
I am forced to use fence_virsh in my setup and now that that virsh has been dropped from the list of luci known agent, I am unable to import my old cluster.conf.

Now, without re-iterating the whole virsh thingy all over again, the list of agents has substantially changed since RHEL5, but it´s theoretically possible to import a rhel5 conf into rhel6 and still get a working cluster.

luci, in case it finds an unsupported agent (that could also be common to custom agents required to run on specific sites), should not error out, but handle the situation a bit more gracefully.

from luci.log:

------------------------------------------------------------
Error - <type 'exceptions.NameError'>: name 'fence_virsh' is not defined
URL: https://luci-rhel6.int.fabbione.net:8084/cluster/fabbione
File '/usr/lib/python2.6/site-packages/weberror/errormiddleware.py', line 162 in __call__
  app_iter = self.application(environ, sr_checker)
[snip endless python error]

I would have expected a message saying that fence_virsh was not supported by luci and life goes on.
Comment 1 Fabio Massimo Di Nitto 2010-07-19 04:17:58 EDT
forgot to mention, this is using the latest code from luci.git
Comment 3 Fabio Massimo Di Nitto 2010-07-26 10:21:44 EDT

*** This bug has been marked as a duplicate of bug 613871 ***

Note You need to log in before you can comment on or make changes to this bug.