Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 615892 - Virtual machines pause all the time. Unable to unpause.
Virtual machines pause all the time. Unable to unpause.
Status: CLOSED DUPLICATE of bug 606131
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 04:37 EDT by Tomas Roos
Modified: 2010-07-20 09:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 09:16:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kerneloops automatically generated (330.00 KB, application/x-tar)
2010-07-19 04:37 EDT, Tomas Roos
no flags Details

  None (edit)
Description Tomas Roos 2010-07-19 04:37:32 EDT
Created attachment 432790 [details]
Kerneloops automatically generated

Description of problem:

I have installed three virtual machines, two RHEL 5.5 and one RHEL 6 Beta 2. On top of RHEL 6 Beta 2. The machines constantly pause.

Version-Release number of selected component (if applicable):

RHEL 6 Beta 2 (from the ISO)

How reproducible:

Start machines, they pause after a while.

Steps to Reproduce:

1. Install RHEL 6 Beta 2
2. Install and start a number of qemu-kvm guests
3. Wait and they will pause.
  
Actual results:

Machine constantly pause and the following is seen in dmesg on the base host doing the virtualization:
EPT: Misconfiguration.
EPT: GPA: 0x73704000
ept_misconfig_inspect_spte: spte 0x1562c9007 level 4
ept_misconfig_inspect_spte: spte 0x228bb9007 level 3
ept_misconfig_inspect_spte: spte 0x401a0f5 level 2
ept_misconfig_inspect_spte: rsvd_bits = 0x1a000
------------[ cut here ]------------
WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+0x220/0x240 [kvm_intel]() (Tainted: G        W )
Hardware name: PowerEdge M610
Modules linked in: tun(U) nfs(U) lockd(U) fscache(U) nfs_acl(U) auth_rpcgss(U) ebtable_nat(U) ebtables(U) ipt_MASQUERADE(U) iptable_nat(U) nf_nat(U) autofs4(U) sunrpc(U) cpufreq_ondemand(U) acpi_cpufreq(U) freq_table(U) bridge(U) stp(U) llc(U) xt_physdev(U) ip6t_REJECT(U) nf_conntrack_ipv6(U) ip6table_filter(U) ip6_tables(U) be2iscsi(U) bnx2i(U) cnic(U) uio(U) cxgb3i(U) cxgb3(U) mdio(U) ib_iser(U) rdma_cm(U) ib_cm(U) iw_cm(U) ib_sa(U) ib_mad(U) ib_core(U) ib_addr(U) ipv6(U) iscsi_tcp(U) libiscsi_tcp(U) libiscsi(U) scsi_transport_iscsi(U) ext2(U) dm_mirror(U) dm_region_hash(U) dm_log(U) dm_round_robin(U) dm_multipath(U) kvm_intel(U) kvm(U) uinput(U) dcdbas(U) iTCO_wdt(U) iTCO_vendor_support(U) i7core_edac(U) edac_core(U) sg(U) bnx2(U) ext3(U) jbd(U) mbcache(U) sd_mod(U) crc_t10dif(U) mptsas(U) mptscsih(U) mptbase(U) scsi_transport_sas(U) lpfc(U) scsi_transport_fc(U) scsi_tgt(U) dm_mod(U) [last unloaded: microcode]
Pid: 5248, comm: qemu-kvm Tainted: G        W  2.6.32-37.el6.x86_64 #1
Call Trace:
 [<ffffffff8106a703>] warn_slowpath_common+0x83/0xc0
 [<ffffffff8106a754>] warn_slowpath_null+0x14/0x20
 [<ffffffffa01e66c0>] handle_ept_misconfig+0x220/0x240 [kvm_intel]
 [<ffffffffa01e967d>] vmx_handle_exit+0xbd/0x240 [kvm_intel]
 [<ffffffffa019d5c7>] kvm_arch_vcpu_ioctl_run+0x3c7/0xd90 [kvm]
 [<ffffffffa01891b2>] kvm_vcpu_ioctl+0x522/0x670 [kvm]
 [<ffffffff8117c8a2>] vfs_ioctl+0x22/0xa0
 [<ffffffff8117cd6a>] do_vfs_ioctl+0x3aa/0x580
 [<ffffffff814d7c76>] ? thread_return+0x4e/0x768
 [<ffffffffa0195043>] ? kvm_on_user_return+0x73/0x80 [kvm]
 [<ffffffff8117cfc1>] sys_ioctl+0x81/0xa0
 [<ffffffff81013172>] system_call_fastpath+0x16/0x1b
---[ end trace 1c26a884199e11d4 ]---
[root@selxkvm01 ~]# virsh list
 Id Name                 State
----------------------------------
  1 kvmtest03            running
  2 kvmtest02            paused
  3 kvmtest01            paused



Expected results:
This should not happen at all?

Additional info:

ksmd is running. Can this be the problem?
Comment 2 RHEL Product and Program Management 2010-07-19 04:57:51 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Andrea Arcangeli 2010-07-20 09:16:37 EDT

*** This bug has been marked as a duplicate of bug 606131 ***
Comment 4 Andrea Arcangeli 2010-07-20 09:17:28 EDT
please try with the build in this comment:


https://bugzilla.redhat.com/show_bug.cgi?id=606131#c41

Note You need to log in before you can comment on or make changes to this bug.