Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615926 - luci does not handle qdisk / cman config correctly
luci does not handle qdisk / cman config correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Brian Brock
:
: 616380 (view as bug list)
Depends On:
Blocks: 620679
  Show dependency treegraph
 
Reported: 2010-07-19 05:41 EDT by Fabio Massimo Di Nitto
Modified: 2016-04-26 10:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: luci-0.22.2-12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 620679 (view as bug list)
Environment:
Last Closed: 2010-11-10 17:12:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2010-07-19 05:41:13 EDT
always latest code from git.

import a very basic cluster config:

<?xml version="1.0"?>
<cluster>
 <clusternodes>
  <clusternode name="rhel6-node1" nodeid="1" votes="1"/>
  <clusternode name="rhel6-node2" nodeid="2" votes="1"/>
 </clusternodes>
</cluster>

luci automatically adds:

<cman expected_votes="1" two_node="1"/>

that is OK.

Later in the process add a qdisk device by label with one ping heuristic.

the cman section should go away and the whole cluster restarted (including qdiskd).

Instead, the cman section is still there and qdiskd is not running.
Comment 3 Fabio Massimo Di Nitto 2010-07-26 10:32:09 EDT
*** Bug 616380 has been marked as a duplicate of this bug. ***
Comment 7 Ryan McCabe 2010-08-03 02:16:07 EDT
Fixed in git commit d0fab117082f7081b5d9675fbddf0945fe0763a4
Comment 8 Fabio Massimo Di Nitto 2010-08-03 05:12:24 EDT
the commit seems to fix the issue
Comment 26 releng-rhel@redhat.com 2010-11-10 17:12:03 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.