Bug 615970 - impress: 'custom animation' does not work
Summary: impress: 'custom animation' does not work
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-19 12:08 UTC by Michal Hlavinka
Modified: 2010-10-05 14:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 14:52:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer file (261.57 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2010-07-19 12:08 UTC, Michal Hlavinka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 114420 None None None Never

Description Michal Hlavinka 2010-07-19 12:08:57 UTC
Created attachment 432842 [details]
reproducer file

Description of problem:
I have powerpoint file with simple animation in one slide (a few images). I can see all images in task window->custom animation

Version-Release number of selected component (if applicable):
openoffice.org-impress-3.2.0-12.25.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1.open reproducer.pptx
2.view->slideshow
  
Actual results:
only empty slide, after clicking a few times, last picture appears and thats all

Expected results:
working animation

Additional info:
in ms office this works as expected

Comment 1 Caolan McNamara 2010-07-20 11:13:10 UTC
definitely busted anyway, reproducible

Comment 2 Caolan McNamara 2010-07-20 13:27:40 UTC
Looks like one way to fix this would be to tweak the animation sequence import to split out the step to take after an animation into a standalone sequence of its own

Comment 3 Caolan McNamara 2010-07-20 14:25:10 UTC
Hmm, and I see that the .ppt import attempts to do this. The .pptx has various ugly cut and pasted .ppt in it, but not that fix up attempt stuff. Ugly, real ugly


Note You need to log in before you can comment on or make changes to this bug.