Bug 615980 - Recipe uploaded via file upload control displays only a portion of recipe uploaded in IE
Summary: Recipe uploaded via file upload control displays only a portion of recipe upl...
Status: CLOSED DUPLICATE of bug 615978
Alias: None
Product: RHQ Project
Classification: Other
Component: Provisioning   
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon24-provisioning
TreeView+ depends on / blocked
 
Reported: 2010-07-19 12:26 UTC by Sunil Kondkar
Modified: 2010-07-19 14:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 14:29:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (46.77 KB, image/png)
2010-07-19 12:26 UTC, Sunil Kondkar
no flags Details
recipe file (1.38 KB, text/xml)
2010-07-19 12:27 UTC, Sunil Kondkar
no flags Details

Description Sunil Kondkar 2010-07-19 12:26:02 UTC
Created attachment 432850 [details]
Screenshot

Description of problem:

If a user uploads a recipe file (refer the attached example recipe file 'deploy.xml'), only a portion of the file is uploaded and is shown in the recipe text area. 

Please refer the attached screenshot.

Tested and observed the issue in IE 6, IE7 and IE8,

Below are the IE versions:

IE6: 6.0.2900.5512.xpsp_sp3_gdr.100216-1514
IE7: 7.0.5730.11
IE8: 8.0.6001.18702

Version-Release number of selected component (if applicable):

jon-2.4.0.GA_QA build#69

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Only a portion of the recipe file is uploaded.

Expected results:

All the content of recipe file should be uploaded and should be displayed in the recipe text area.

Additional info:

Comment 1 Sunil Kondkar 2010-07-19 12:27:27 UTC
Created attachment 432851 [details]
recipe file

Comment 2 John Mazzitelli 2010-07-19 14:23:24 UTC
This is a known limitation of the direct "upload via recipe" feature. I
documented this in our dev wiki here:

http://rhq-project.org/display/RHQ/Design+-+Policy

which yes is hidden away. Should probably put this in our user docs somewhere.

Specifically, the yellow box that says:

"For some reason, if you file upload a ANT script as the recipe, you can't use
XML notation like <property name="a" /> - you need to explicitly provide the
ending tag like this: <property name="a"></property>. If you don't want to be
forced into using that notation, just copy-n-paste the ANT script content
directly in the text field, as opposed to using the file upload mechanism."

Fix the rhq:input-property tag in the attached deploy.xml so it doesn't use the
<tag/> notation and try again. No tags should use the <tag/> notation when you
directly upload the recipe xml.

NOTE: this is ONLY a limitation when uploading the recipe directly - when
uploading a bundle distribution file, your XML can have <tag/> notation.

Moving back to ON_QA to test using a different XML file.

Comment 3 Charles Crouch 2010-07-19 14:29:50 UTC
Closing this as we should already cover this case when testing https://bugzilla.redhat.com/show_bug.cgi?id=615978

*** This bug has been marked as a duplicate of bug 615978 ***


Note You need to log in before you can comment on or make changes to this bug.