Bug 615985 - dual head xrandr doesn't seem to work with gnome-shell
dual head xrandr doesn't seem to work with gnome-shell
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 08:38 EDT by Mildred
Modified: 2011-05-25 18:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-25 18:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mildred 2010-07-19 08:38:46 EDT
Description of problem:

When I connect a second screen to the VGA output of my laptop, gnome-shell seems to crash. I get an extended screen automatically (I see my wallpaper on the external screen and can have my mouse cursor on it).

But, all windows seem minimized such as I only see the wallpaper and can't see any windows. Alt-Tab doesn't work. Top-Left screen corner doesn't work either. I can't see the top bar from the gnome-shell (where you can find the activities button and all the notification icons).

In order to get my desktop working again, I disconnect my external screen. Then I suppose gnome-session restarts gnome-shell and everything is back as expected.



Version-Release number of selected component: gnome-shell-2.29.1-4

How reproducible: always

Steps to Reproduce:
  1. enable gnome-shell
  2. plug in an external screen 

Actual results: can't use the desktop, gnome-shell seem to have crashed

Expected results: can use the desktop normally

Additional info: Using intel xorg driver
Comment 1 Mildred 2010-08-27 04:01:51 EDT
Still happens on rawhide

SMOLT profile: http://www.smolts.org/client/show/pub_eee073ef-5435-4449-8a7b-42793b31248b
Comment 2 Mildred 2010-09-04 09:10:03 EDT
It kind of works if the screen is rectangular (both screens when added up form a big rectangular screen). But then, in the activity view, the screen size is incorrect.
Comment 3 Dan Winship 2011-03-29 16:01:57 EDT
is this still a problem with the latest packages? a lot of work has gone into multihead setups since then.
Comment 4 Owen Taylor 2011-05-25 18:02:51 EDT
No response, assuming problems have been addressed.

Note You need to log in before you can comment on or make changes to this bug.