Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615996 - lockup in bonding on bnx2x
lockup in bonding on bnx2x
Status: CLOSED DUPLICATE of bug 578531
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Stanislaw Gruszka
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 09:10 EDT by Stanislaw Gruszka
Modified: 2010-07-19 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 11:38:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislaw Gruszka 2010-07-19 09:10:37 EDT
Version-Release number of selected component:
kernel-2.6.18-194.el5 (this is regresion older RHEL5.4 kernlel -164 works)

How reproducible:
100%

Steps to Reproduce:
(on both back-to-back connected servers do)
modprobe 8021q
insmod bnx2x/src/bnx2x.ko
modprobe bonding mode=6 miimon=100
ifconfig bond0 up
ifenslave bond0 eth4 #port one of 57711 device
ifenslave bond0 eth5 #port two of 57711 device
vconfig add bond0 7
ifconfig bond0.7 192.168.10.${SERVIP}
try to ping machine with RH55

Actual results:
> Jul 18 16:43:43  kernel: BUG: soft lockup - CPU#2 stuck for 10s! [swapper:0]
> Jul 18 16:43:43  kernel: CPU 2:
> Jul 18 16:43:43  kernel: Modules linked in: bnx2x(U) bonding autofs4 hidp rfcomm l2cap bluetooth lockd sunrpc ipv6 xfrm_nalgo crypto_api loop dm_mirror dm_multipath scsi_dh video backlight sbs power_meter hwmon i2c_ec i2c_cor
> e dell_wmi wmi button battery asus_acpi acpi_memhotplug ac parport_pc lp parport ide_cd i5000_edac hpilo edac_mc cdrom bnx2 8021q pcspkr serio_raw dm_raid45 dm_message dm_region_hash dm_log dm_mod dm_mem_cache ata_piix libata shpchp cciss
> sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd ehci_hcd
> Jul 18 16:43:43  kernel: Pid: 0, comm: swapper Tainted: G      2.6.18-197.el5.bnx2x_test #1
> Jul 18 16:43:43  kernel: RIP: 0010:[<ffffffff80064c20>]  [<ffffffff80064c20>] .text.lock.spinlock+0x26/0x30
> Jul 18 16:43:43  kernel: RSP: 0018:ffff81023ff6bcc0  EFLAGS: 00000286
> Jul 18 16:43:43  kernel: RAX: ffff81023ff67fd8 RBX: ffff81023ad8eec0 RCX: ffff81023ad8e800
> Jul 18 16:43:43  kernel: RDX: ffff810231466710 RSI: ffff81023ad8e800 RDI: ffff81023ad8ef58
> Jul 18 16:43:43  kernel: RBP: ffff81023ff6bc40 R08: 0000000000000000 R09: ffff81023f682380
> Jul 18 16:43:43  kernel: R10: 0000000000000000 R11: 00000000000000c8 R12: ffffffff8005dc8e
> Jul 18 16:43:43  kernel: R13: ffff81023ad8ef58 R14: ffffffff8007820e R15: ffff81023ff6bc40
> Jul 18 16:43:43  kernel: FS:  0000000000000000(0000) GS:ffff81023ff26e40(0000) knlGS:0000000000000000
> Jul 18 16:43:43  kernel: CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
> Jul 18 16:43:43  kernel: CR2: 000000000f3f63d0 CR3: 000000023410d000 CR4: 00000000000006e0
> Jul 18 16:43:43  kernel:
> Jul 18 16:43:43  kernel: Call Trace:
> Jul 18 16:43:43  kernel:  <IRQ>  [<ffffffff8849bffa>] :bonding:rlb_arp_recv+0xb2/0x146
> Jul 18 16:43:43  kernel:  [<ffffffff80020916>] netif_receive_skb+0x43e/0x49f
> Jul 18 16:43:43  kernel:  [<ffffffff884e721b>] :bnx2x:bnx2x_rx_int+0xfd4/0x1138
> Jul 18 16:43:43  kernel:  [<ffffffff8008102e>] cacheinfo_cpu_callback+0x4e2/0x516
> Jul 18 16:43:43  kernel:  [<ffffffff80150031>] __bitmap_shift_right+0xd/0x123
> Jul 18 16:43:43  kernel:  [<ffffffff80081031>] cacheinfo_cpu_callback+0x4e5/0x516
> Jul 18 16:43:43  kernel:  [<ffffffff884e970a>] :bnx2x:bnx2x_poll+0x82/0x2d5
> Jul 18 16:43:43  kernel:  [<ffffffff8000c85b>] net_rx_action+0xac/0x1e0
> Jul 18 16:43:43  kernel:  [<ffffffff80012383>] __do_softirq+0x89/0x133
> Jul 18 16:43:43  kernel:  [<ffffffff8005e2fc>] call_softirq+0x1c/0x28
> Jul 18 16:43:43  kernel:  [<ffffffff8006cb8e>] do_softirq+0x2c/0x85
> Jul 18 16:43:43  kernel:  [<ffffffff8006ca16>] do_IRQ+0xec/0xf5
> Jul 18 16:43:43  kernel:  [<ffffffff80056ede>] mwait_idle+0x0/0x4a
> Jul 18 16:43:43  kernel:  [<ffffffff8005d615>] ret_from_intr+0x0/0xa
> Jul 18 16:43:43  kernel:  <EOI>  [<ffffffff80056f14>] mwait_idle+0x36/0x4a
> Jul 18 16:43:43  kernel:  [<ffffffff800490cc>] cpu_idle+0x95/0xb8
> Jul 18 16:43:43  kernel:  [<ffffffff8007797a>] start_secondary+0x498/0x4a7
Comment 1 Andy Gospodarek 2010-07-19 11:38:43 EDT

*** This bug has been marked as a duplicate of bug 578531 ***

Note You need to log in before you can comment on or make changes to this bug.