This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 61603 - NIS/YP user login returns account expired error
NIS/YP user login returns account expired error
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-21 19:32 EST by Joseph Kotran
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 07:30:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Kotran 2002-03-21 19:32:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
Attempts to login using a NIS/YP account return an error message that states
that the account is expired.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure Red Hat 7.2.92 as a NIS/YP client.
2.Login using a NIS/YP account.


Actual Results:  This is logged in /var/log/secure:

Mar 21 16:20:02 hostname login: User account has expired

Also, the user login is rejected.


Expected Results:  The user should be able to login.


Additional info:

This may or may not be a pam problem.  It could be a ypbind problem.  I suggest
pam, because I executed strace against a login process to record the system
calls that the login process makes when a NIS user login fails.  I noticed in
the output serveral references to pam.

Please note that local user accounts are able to login.

In both cases (NIS and local) I am using shadow password without MD5 encryption.
 No account expiration has been set in either case.  I also tested by setting an
expiration date in the future.  The login still failed.
Comment 1 Michael Redinger 2002-03-23 11:31:19 EST
Same here. The same configuration works fine with 7.2.
I'm using plain crypt, no MD5. NIS doesn't use shadow passwords.
Downgrading ypbind to the 7.2 version didn't help.
So I also downgraded to pam-0.75-19 from the 7.2 updates. Still the same message.
I then went back to the original 7.2 version (0.75-14). Now I didn't get account
expired but FAILED LOGIN. However, IIRC this version had pam issues.
Comment 2 Tomas Mraz 2004-10-20 04:20:56 EDT
This report is too old. Please retest with current Fedora Core releases.
Comment 3 Tomas Mraz 2004-11-16 07:30:47 EST
No response.

Note You need to log in before you can comment on or make changes to this bug.