Bug 616045 - system-config-display fails to start (IndexError: index out-of-bounds)
system-config-display fails to start (IndexError: index out-of-bounds)
Status: CLOSED DUPLICATE of bug 493680
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 10:23 EDT by Cristian Ciupitu
Modified: 2010-11-05 11:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-05 01:08:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current /etc/X11/xorg.conf (268 bytes, text/plain)
2010-07-19 10:23 EDT, Cristian Ciupitu
no flags Details
/var/log/Xorg.0.log (72.23 KB, text/plain)
2010-07-19 10:25 EDT, Cristian Ciupitu
no flags Details

  None (edit)
Description Cristian Ciupitu 2010-07-19 10:23:31 EDT
Created attachment 432900 [details]
current /etc/X11/xorg.conf

Description of problem:
system-config-display fails to start

Version-Release number of selected component (if applicable):
system-config-display-2.2-1.fc12.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Run system-config-display
  
Actual results:
[root@hermes ~]# system-config-display 
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 378, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 641, in __init__
    if len(self.xconfig.layout[0].adjacencies) > 1:
IndexError: index out-of-bounds

Expected results:
No errors.

Additional info:
I have an NVidia GS 7600 card and only xorg-x11-drv-nouveau-0.0.16-7.20100423git13c1043.fc13.x86_64.rpm (no nv or nvidia).
Comment 1 Cristian Ciupitu 2010-07-19 10:25:12 EDT
Created attachment 432902 [details]
/var/log/Xorg.0.log

For some strange reason my current resolution is 1280x1024, even if the LCD monitor conencted via DVI can do 1920x1200.
Comment 2 Ankur Sinha (FranciscoD) 2010-11-05 01:08:29 EDT

*** This bug has been marked as a duplicate of bug 493680 ***

Note You need to log in before you can comment on or make changes to this bug.