Bug 616049 - Please update rubygem-haml to 3.0.13
Please update rubygem-haml to 3.0.13
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rubygem-haml (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Mo Morsi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 616048
  Show dependency treegraph
 
Reported: 2010-07-19 10:29 EDT by Tomas Sedovic
Modified: 2011-03-29 14:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-29 14:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Sedovic 2010-07-19 10:29:23 EDT
Description of problem:
The version available in Fedora 13 is quite behind.

Version-Release number of selected component (if applicable):
2.2.24

Expected results:
yum installs rubygem-haml version 3.0.13

Additional info:
We're using HAML in Deltacloud. It would be great if our users could install the supported version via yum.
Comment 1 Matthew Kent 2010-07-28 02:30:11 EDT
Apologies for the delay - will examine this tomorrow.
Comment 2 Matthew Kent 2010-07-29 02:23:38 EDT
Updated - build here

http://koji.fedoraproject.org/koji/taskinfo?taskID=2356553

unable to update packages for a bit due to cvs maintenance.

Looks like the new haml breaks rubygem-compass so I'll need to file a ticket to get that resolved before it can go up for F13.
Comment 3 Mo Morsi 2010-09-21 16:11:44 EDT
ping?

Can you elaborate on the compass incompatibility. Is this just for version 3.0.13, if so perhaps we can only update to a slightly older version until these incompatibilities have been resolved upstream.

Recent versions of compass (which I maintain) specify 3.0.4 as the minimum. We need the updated haml, to update compass, to also include the compass-960-plugin package which we also need for deltacloud.

The request to update compass can be found here
https://bugzilla.redhat.com/show_bug.cgi?id=616048
Comment 4 Michal Fojtik 2010-10-04 10:07:49 EDT
+1
Comment 5 Michal Fojtik 2010-10-20 07:00:38 EDT
ping again, is there any progress ?
Comment 6 Michal Fojtik 2010-10-26 06:10:40 EDT
Another reason for update is that new Sinatra (1.1) depends on HAML >=3.0.
HAML 3.0 introduces SCSS parsers which are the most wanted feature for most Sinatra hackers ;-)
As mmorsi said, we can elaborate with compass update as well.
Comment 7 Mamoru TASAKA 2010-10-26 14:26:00 EDT
(While I know almost nothing about haml)
Are there any reason haml should be updated to 3.x even on F-13?

As F-14 is to be released, basically updates on F-13 should be bugfix
only and introducing incompatibility with currently shipped version
must be avoided:
https://fedoraproject.org/wiki/Updates_Policy#Philosophy

Also (again while I don't know about haml well), I am not sure if
haml should be updated to 3.x even on F-14.
Comment 8 Mamoru TASAKA 2010-10-26 17:03:39 EDT
Also http://haml-lang.com/docs/yardoc/file.HAML_CHANGELOG.html
says there is some incompatibility between 2.2.24 and 3.0.0.
Comment 9 Matthew Kent 2010-10-27 01:41:10 EDT
Anyone have time to help maintain? I've got my hands full with a few other projects atm.
Comment 10 Fedora Admin XMLRPC Client 2011-01-14 02:11:40 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Mo Morsi 2011-03-29 14:33:37 EDT
I've updated haml to the latest upstream release in rawhide and F15. 

F15 updates push is pending successful build which is pending updates to dependencies (rails has just been updated from 3.0.3 to 3.0.5 and is in f15-updates-testing, those changes need to make it through to updates for a successful haml build).

http://pkgs.fedoraproject.org/gitweb/?p=rubygem-haml.git;a=commitdiff;h=15f204868c144511241083f2621b6fc5adc9b60b

Note You need to log in before you can comment on or make changes to this bug.