Bug 61615 - date +%p broken for en_AU locale
date +%p broken for en_AU locale
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-21 23:36 EST by Damien Miller
Modified: 2016-11-24 09:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 14:46:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damien Miller 2002-03-21 23:36:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020212

Description of problem:
"date +%p" does not work for the en_AU locate. Instead of printing AM or PM it
prints an empty string.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Execute "LANG=en_AU date +%p"
2. Execute "LANG=en_US date +%p"


Actual Results:  [djm@xenon djm]$ LANG=en_AU date +%p

[djm@xenon djm]$ LANG=en_US date +%p
PM


Expected Results:  [djm@xenon djm]$ LANG=en_AU date +%p
PM
[djm@xenon djm]$ LANG=en_US date +%p
PM


Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-03-25 09:32:51 EST
What date shows you is the output of the strptime() function in glibc; it seems to be 
gererating wrong data (This may be intentional though if Australia defaults to the 24 
hours system). 
 
Reassigning to glibc
Comment 2 Alan Cox 2002-12-15 14:46:30 EST
This was fixed bug the bug didnt get closed.

Note You need to log in before you can comment on or make changes to this bug.