Bug 61618 - crashed while trying to start the login manament as a non-root user
crashed while trying to start the login manament as a non-root user
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-22 00:41 EST by Chris Ricker
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-22 00:41:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-03-22 00:41:39 EST
Here's the output.....  As mentioned, this happened while starting login manager
as non-root

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1024 (LWP 17155)]
0x40fd43a9 in wait4 () from /lib/libc.so.6
#0  0x40fd43a9 in wait4 () from /lib/libc.so.6
#1  0x4104be8c in __DTOR_END__ () from /lib/libc.so.6
#2  0x40e9880a in waitpid () from /lib/libpthread.so.0
#3  0x4068d362 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4
#4  0x40e962fb in pthread_sighandler () from /lib/libpthread.so.0
#5  <signal handler called>
#6  0x41459ef3 in KGlobalBackgroundSettings::deskName ()
   from /usr/lib/kde3/kcm_background.so
#7  0x414339fa in KBackground::init () from /usr/lib/kde3/kcm_background.so
#8  0x418aa14b in KBackground::KBackground () from /usr/lib/kde3/kcm_kdm.so
#9  0x418b9557 in KDModule::KDModule () from /usr/lib/kde3/kcm_kdm.so
#10 0x418c718a in KGenericFactory<KDModule, QWidget>::createObject ()
   from /usr/lib/kde3/kcm_kdm.so
#11 0x406a354e in KLibFactory::create () from /usr/lib/libkdecore.so.4
#12 0x412ccfb6 in KCModule *
KParts::ComponentFactory::createInstanceFromFactory<KCModule> () from
/usr/lib/kcontrol.so
#13 0x412ccf43 in KCModule *
KParts::ComponentFactory::createInstanceFromLibrary<KCModule> () from
/usr/lib/kcontrol.so
#14 0x412c1025 in load () from /usr/lib/kcontrol.so
#15 0x412c147c in ModuleLoader::loadModule () from /usr/lib/kcontrol.so
#16 0x412bef3f in ConfigModule::module () from /usr/lib/kcontrol.so
#17 0x412c2496 in DockContainer::dockModule () from /usr/lib/kcontrol.so
#18 0x412b9d43 in TopLevel::activateModule () from /usr/lib/kcontrol.so
#19 0x412b8fe3 in TopLevel::moduleActivated () from /usr/lib/kcontrol.so
#20 0x412b7862 in TopLevel::qt_invoke () from /usr/lib/kcontrol.so
#21 0x4094bee7 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x412ba52c in IndexWidget::moduleActivated () from /usr/lib/kcontrol.so
#23 0x412ba99a in IndexWidget::moduleSelected () from /usr/lib/kcontrol.so
#24 0x412ba6a3 in IndexWidget::qt_invoke () from /usr/lib/kcontrol.so
#25 0x4094bee7 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x412c63bc in ModuleTreeView::moduleSelected () from /usr/lib/kcontrol.so
#27 0x412c76bf in ModuleTreeView::slotItemSelected () from /usr/lib/kcontrol.so
#28 0x412c64d4 in ModuleTreeView::qt_invoke () from /usr/lib/kcontrol.so
#29 0x4094bee7 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x4045589c in KListView::executed () from /usr/lib/libkdeui.so.4
#31 0x4044f103 in KListView::emitExecute () from /usr/lib/libkdeui.so.4
#32 0x4044fb61 in KListView::slotMouseButtonClicked ()
   from /usr/lib/libkdeui.so.4
#33 0x404565c9 in KListView::qt_invoke () from /usr/lib/libkdeui.so.4
#34 0x412c64c2 in ModuleTreeView::qt_invoke () from /usr/lib/kcontrol.so
#35 0x4094bee7 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x40c44d5a in QListView::mouseButtonClicked ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x40a1e7d7 in QListView::contentsMouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0x4044fa20 in KListView::contentsMouseReleaseEvent ()
   from /usr/lib/libkdeui.so.4
#39 0x40a46727 in QScrollView::viewportMouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0x40a45e24 in QScrollView::eventFilter ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0x40a1ce9e in QListView::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0x4094abfb in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0x4094aabb in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0x4097b1b1 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0x408f0113 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0x408ef843 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0x405f2aeb in KApplication::notify () from /usr/lib/libkdecore.so.4
#48 0x40899ab1 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0x40896da0 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0x408959fe in QApplication::processNextEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0x408f159c in QApplication::enter_loop ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#52 0x40895967 in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#53 0x412b75d6 in main () from /usr/lib/kcontrol.so
#54 0x0804cea9 in strcpy ()
#55 0x0804db8c in strcpy ()
#56 0x0804dfd6 in strcpy ()
#57 0x0804f4c5 in strcpy ()
#58 0x40f40a34 in __libc_start_main () from /lib/libc.so.6
Comment 1 Bernhard Rosenkraenzer 2002-03-25 09:54:23 EST
Can't reproduce it with the current version.

Note You need to log in before you can comment on or make changes to this bug.