Bug 61619 - PHP should have mysql.default_socket configured in php.ini
PHP should have mysql.default_socket configured in php.ini
Status: CLOSED DUPLICATE of bug 60515
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-22 01:37 EST by Oliver Schulze L.
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-22 01:38:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Schulze L. 2002-03-22 01:37:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
PHP should have this line:
  mysql.default_socket = /var/lib/mysql/mysql.sock
in the file:
  /etc/php.ini

Beacuse MySQL use by default the file socket /tmp/mysql.sock which one does not
exists

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. connect from a .php file to mysql
2. use localhost as the default host
3. you can't and get an error
	

Actual Results:  You can't connect to MySQL from PHP if you do not configure
/etc/php.ini

Expected Results:  you should be able to connect from PHP to MySQL using the
file socket /var/lib/mysql/mysql.sock

If you have a clean instalation of RedHat 7.2, you should be able to use MySQL
and PHP without the need to edit /etc/php.ini
This was the normal behavior in RH 7.1


Additional info:
Comment 1 Phil Copeland 2002-03-22 02:29:27 EST

*** This bug has been marked as a duplicate of 60515 ***

Note You need to log in before you can comment on or make changes to this bug.