Bug 616243 - Trackpad on Dell Precision M4500 not recognized
Trackpad on Dell Precision M4500 not recognized
Status: CLOSED DUPLICATE of bug 590880
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 17:40 EDT by linux4fun
Modified: 2010-11-02 08:08 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-02 08:08:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description linux4fun 2010-07-19 17:40:17 EDT
Description of problem:
The trackpad of Dell Precision M4500 is not recognized as such, but instead, as a PS/2 Generic Mouse, thus it is not possible to use scrolling ...


Version-Release number of selected component (if applicable):
Might be linked to Bug #590880 however I do not have the technical knowledge to make the checks, debug the module and retrieve the device code.

How reproducible:
Always

Actual results:
The trackpad and track stick have basic mouse functionalities and are not
visible via synclient.

Additional info:
# synclient -l
Couldn't find synaptics properties. No synaptics driver loaded?
# grep ALPS  /var/log/Xorg.0.log
(nothing found)
Comment 1 Johnny Hughes 2010-08-13 12:28:26 EDT
This patch has been added upstream:

https://patchwork.kernel.org/patch/118834/
Comment 2 Chuck Ebbert 2010-08-17 00:18:39 EDT
(In reply to comment #1)
> This patch has been added upstream:
> 
> https://patchwork.kernel.org/patch/118834/

That patch is not even in input.git yet.
Comment 3 Alex Tucker 2010-09-09 10:10:49 EDT
I've just applied the patch referenced in comment #2 to kernel-2.6.34.6-47.fc13.src.rpm, and it works fine for me on my DELL Precision M4500, enabling the scrolling functions.
Comment 4 Alex Tucker 2010-09-09 16:39:03 EDT
Having said that, and now having gone through a suspend/resume cycle, the mouse pointer went crazy on resume, so I don't think it's quite there yet.
Comment 5 Jan Vcelak 2010-11-02 08:08:18 EDT

*** This bug has been marked as a duplicate of bug 590880 ***

Note You need to log in before you can comment on or make changes to this bug.