Bug 61628 - pppd dialin problem to MS RAS server with CBCP
pppd dialin problem to MS RAS server with CBCP
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.2
All Linux
high Severity high
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-22 05:36 EST by Jarek Polok
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 12:03:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file from failed attempt (2.88 KB, text/plain)
2002-03-22 05:41 EST, Jarek Polok
no flags Details
patch to disable CBCP negotiation by default (638 bytes, patch)
2002-03-22 05:43 EST, Jarek Polok
no flags Details | Diff

  None (edit)
Description Jarek Polok 2002-03-22 05:36:59 EST
Description of Problem:

pppd cannot connect as dialin only to MS RAS servers offering dialin and CBCP callback
at the same time. Server requests disconnect.

Version-Release number of selected component (if applicable):

ppp-2.4.1-2

How Reproducible:

Always, just dialin into server offering at the same time dialin and CBCP 
(and DO NOT use option 'callback', just try dialin)

Actual Results:

Received TermReq in LCP phase from the server

Expected Results:

Succesfull dialin ;-)


Additional Information:
 
The problem comes from the fact that:
1. CBCP protocol is disabled by default (unless 'callback' option specified)
(in pppd/cbcp.c protent_cbcp) AND
2. CBCP negotiation is enabled by default (in pppd/lcp.c)
which seems useless if no 'callback' option used (which enables both protocol and negotiation)

See attached proposed patch and log excerpt from failed negotiation (basically local pppd 
acknowledged CBCP, then rejected CBCP packet. in response server requested
termination ... )
Comment 1 Jarek Polok 2002-03-22 05:41:45 EST
Created attachment 49626 [details]
log file from failed attempt
Comment 2 Jarek Polok 2002-03-22 05:43:25 EST
Created attachment 49627 [details]
patch to disable CBCP negotiation by default
Comment 3 Jarek Polok 2002-03-22 05:48:22 EST
One thing more:

Above problem most likely affects also ipppd from isdn4k-utils-3.1-46 (looking at the
source code, exactly same thing happens there).


Comment 4 Jarek Polok 2002-05-02 03:19:25 EDT
Hello

Pity that before releasing ppp-2.4.1-3 update [RHBA-2002:037-04] you have not checked
THIS bug report, instead of doing things like:

* Wed Feb 27 2002 Nalin Dahyabhai <nalin@redhat.com> 2.4.1-3
- revert cbcp patch, it's wrong (#55367)

you could fix it properly, using the patch I've attached .... (on 22 March !)

Anyway I hope this WILL be fixed properly in the next update.
(CBCP is really something some people HAVE to use ... because their access
provider supports only this ...)

To get the message through this time I've raised the priority and severity fields in the report ...

Regards

Jarek





 
Comment 5 Thomas Woerner 2004-08-16 12:03:56 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.