Bug 616291 - Login keyring isn't unlocked when using automatic login
Login keyring isn't unlocked when using automatic login
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: accountsdialog (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 23:46 EDT by Iván Jiménez
Modified: 2010-07-21 21:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 21:10:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log messages (613.43 KB, text/plain)
2010-07-19 23:56 EDT, Iván Jiménez
no flags Details
xsession-errors (1.66 KB, text/plain)
2010-07-19 23:56 EDT, Iván Jiménez
no flags Details

  None (edit)
Description Iván Jiménez 2010-07-19 23:46:55 EDT
Description of problem:
In accountsdialog's Login Options I set Automatic Login: Mario, which is the only user on this fresh installation, but in every login, there is a dialog saying "Enter password for to unlock your login keyring. The login keyring did not get unlocked when you logged into your computer.", after I enter my user's password, the wireless network connects. If Automatic Login is disabled, it connects automatically without dialog. It would be really nice if the keyring were automatically unlocked because it'd be a no questions boot up experience.

[mario@localhost ~]$ ls .gnome2/keyrings/
default  login.keyring  user.keystore

cat .gnome2/keyrings/default 
login

Version-Release number of selected component (if applicable):
accountsdialog-0.6-3.fc13.x86_64
accountsservice-0.6-2.fc13.x86_64
gnome-keyring-2.30.3-1.fc13.x86_64
libgnome-keyring-2.30.1-1.fc13.x86_64
NetworkManager-glib-0.8.1-0.1.git20100510.fc13.x86_64
NetworkManager-0.8.1-0.1.git20100510.fc13.x86_64
NetworkManager-gnome-0.8.1-0.1.git20100510.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. store a secret in the default keyring (a network pw would be used at every login)
2. enable automatic login
3. reboot

It's easy to reproduce because if I log out when using automatic login, a new session is started immediately and the dialog appears.

Actual results:
a dialog

Expected results:
no dialog and network should be connected 

Additional info:
I will attach messages and .xsession-errors, please let me know if there's additional info needed.
Comment 1 Iván Jiménez 2010-07-19 23:56:05 EDT
Created attachment 433055 [details]
log messages
Comment 2 Iván Jiménez 2010-07-19 23:56:53 EDT
Created attachment 433056 [details]
xsession-errors
Comment 3 Matthias Clasen 2010-07-21 21:10:18 EDT
This is not related to the accountsdialog at all. It is a problem with the way the keyring works. It is protected by your password. If you don't enter the password at login, it is not available to unlock the keyring.

I am going to close this bug, since there is not much we can do about this, realistically.

Note You need to log in before you can comment on or make changes to this bug.