Bug 616324 - [ml_IN] 0D4D (unicode) Character is cut if it present at End of Word in Label
[ml_IN] 0D4D (unicode) Character is cut if it present at End of Word in Label
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smc-fonts (Show other bugs)
13
All Linux
high Severity medium
: ---
: ---
Assigned To: Naveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 555678
  Show dependency treegraph
 
Reported: 2010-07-20 03:28 EDT by A S Alam
Modified: 2013-07-02 21:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: smc-fonts-4.4-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 00:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ibus Problem (43.77 KB, image/png)
2010-07-20 03:28 EDT, A S Alam
no flags Details
Cursor position for 0D4D in Meera (4.38 KB, image/png)
2010-07-21 03:41 EDT, Ani Peter
no flags Details
Cursor position for 0D4D in Rachana (5.90 KB, image/png)
2010-07-21 03:52 EDT, Ani Peter
no flags Details
Cursor position for 0D4D in Lohit (4.82 KB, image/png)
2010-07-21 03:53 EDT, Ani Peter
no flags Details
working sfd for Meera (2.45 MB, text/plain)
2010-07-21 05:04 EDT, Pravin Satpute
no flags Details
sfd file working well on pango and icu (2.45 MB, text/plain)
2010-08-02 10:34 EDT, Pravin Satpute
no flags Details
ttf file for testing (326.94 KB, application/octet-stream)
2010-08-02 10:38 EDT, Pravin Satpute
no flags Details
source file with enhancements (2.45 MB, text/plain)
2010-08-10 07:30 EDT, Pravin Satpute
no flags Details
smc-fonts_616324.patch: created from modified file submitted by Pravin S (2.08 KB, patch)
2010-08-16 09:08 EDT, Naveen Kumar
no flags Details | Diff

  None (edit)
Description A S Alam 2010-07-20 03:28:09 EDT
Created attachment 433089 [details]
Ibus Problem

Description of problem:
0D4D (unicode) Character is cut if it present at End of Word in Label. It is
effecting Many applications in Desktop (Malayalam). It appears in Text Editor,
but in real-time, it is not appearing. 

Version-Release number of selected component (if applicable):
smc-meera-fonts-04.2-10.fc13

How reproducible:
100%

Steps to Reproduce:
1. run gedit in malayalam (ml_IN)
2. type 0D4D, check cursor position
3. run ibus-preferences, check 2nd tab Text

Actual results:
Character is cut at last on Tab

Expected results:
it should complete

Additional info:
1) in gedit, paste 
--
പുറകോട്p  
്
--

Check "P" at 1st word, it is mixed with (്) Character
in 2nd row, position of cursor is in-between instead of End of Character

Effected application:
abrt-gui
system-config-firewall
sound-juicer
gnome-system-monitor
gpk-repo
ekiga
Comment 1 Rajeesh 2010-07-20 10:17:15 EDT
(In reply to comment #0)
> Created an attachment (id=433089) [details]
> Ibus Problem
> 
> Description of problem:
> 0D4D (unicode) Character is cut if it present at End of Word in Label. It is
> effecting Many applications in Desktop (Malayalam). It appears in Text Editor,
> but in real-time, it is not appearing. 
> 
> Version-Release number of selected component (if applicable):
> smc-meera-fonts-04.2-10.fc13

I assume this is a problem only with Meera font - is it reproducible with Rachana or any other font?
This might be the same issue of fontconf matrix...
Comment 2 Pravin Satpute 2010-07-20 11:08:19 EDT
(In reply to comment #1)
> 
> I assume this is a problem only with Meera font - is it reproducible with
> Rachana or any other font?
> This might be the same issue of fontconf matrix...    

not, 
this is happening due to Em- square issue of U+0D4D
see its right bearing is just 10, even though it required right bearing at 299

thats why next letter 'P' is merging with U+0D4D

പുറകോട്p

why right bearing is kept so less? 
I think it should be 299+ when U+0D4d will be last character.

same for U+0D02
Comment 3 Ani Peter 2010-07-21 03:40:16 EDT
I have tested this with Meera, Rachana and Lohit. For Meera, the cursor stands before 0D4D (്), Rachana in the middle and Lohit at the end. Screenshots attached
Comment 4 Ani Peter 2010-07-21 03:41:03 EDT
Created attachment 433323 [details]
Cursor position for 0D4D in Meera
Comment 5 Ani Peter 2010-07-21 03:52:50 EDT
Created attachment 433328 [details]
Cursor position for 0D4D in Rachana
Comment 6 Ani Peter 2010-07-21 03:53:19 EDT
Created attachment 433329 [details]
Cursor position for 0D4D in Lohit
Comment 7 Pravin Satpute 2010-07-21 05:04:13 EDT
Created attachment 433345 [details]
working sfd for Meera

was trying to investigate problem with pravi.a and naveen,
by adding dist feature we can resolve this problem, but need to check some exceptional condition as well

attaching .sfd with added dist feature in it, but not complete (and not working for all cases) need to update and test it for all cases
Comment 9 Pravin Satpute 2010-07-27 10:44:09 EDT
resolved this one!!

scratch build is available on http://koji.fedoraproject.org/koji/taskinfo?taskID=2353995

i have tested it from my side so it will not add any regression
please test this and let me know your view on same
Comment 10 Pravin Satpute 2010-07-27 10:51:10 EDT
modified source file is @ http://pravins.fedorapeople.org/Meera.sfd
binary file for testing @ http://pravins.fedorapeople.org/Meera.ttf

patch: http://pravins.fedorapeople.org/bug-616324.patch
Comment 11 Pravin Satpute 2010-07-30 01:52:05 EDT
Naveen can you build this for devel?
Comment 12 Pravin Satpute 2010-08-02 10:34:55 EDT
Created attachment 436040 [details]
sfd file working well on pango and icu

working more on same problem
things word well with Pango and ICU but looks like QT is not processing ZWNJ in gusb and gpos
Comment 13 Pravin Satpute 2010-08-02 10:38:20 EDT
Created attachment 436041 [details]
ttf file for testing
Comment 14 Pravin Satpute 2010-08-06 04:52:36 EDT
(In reply to comment #13)
> Created an attachment (id=436041) [details]
> ttf file for testing    

naveen lets wait for testing of this ttf
then will do build for fedora
Comment 15 Pravin Satpute 2010-08-10 07:30:12 EDT
Created attachment 437843 [details]
source file with enhancements

this file is fixing isssue
i.e when U+0d4d followed by any punctuation mark 
ക്( ക്1 ക്: etc

and also resolved problem of cut for U+0d02 and U+0d03
Comment 16 Pravin Satpute 2010-08-10 07:30:59 EDT
naveen can you build this for fedora?
Comment 17 Naveen Kumar 2010-08-11 03:12:46 EDT
Yep, I will do it.
Comment 18 Naveen Kumar 2010-08-16 09:08:41 EDT
Created attachment 438942 [details]
smc-fonts_616324.patch: created from modified file submitted by Pravin S
Comment 19 Fedora Update System 2010-08-16 10:22:25 EDT
smc-fonts-4.4-2.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/smc-fonts-4.4-2.fc14
Comment 20 Fedora Update System 2010-08-16 12:03:53 EDT
smc-fonts-4.4-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smc-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/smc-fonts-4.4-2.fc14
Comment 21 Fedora Update System 2010-09-14 00:57:14 EDT
smc-fonts-4.4-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.