Bug 61633 - glibc 2.2.5-27 upgrade from 2.2.4-20 fails
Summary: glibc 2.2.5-27 upgrade from 2.2.4-20 fails
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-22 14:03 UTC by sean
Modified: 2017-01-10 12:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 14:02:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1404435 None None None Never

Description sean 2002-03-22 14:03:43 UTC
Description of Problem:

[root@localhost i386]# ls *2.2.5*
glibc-2.2.5-27.i386.rpm         glibc-debug-static-2.2.5-27.i386.rpm 
glibc-utils-2.2.5-27.i386.rpm
glibc-common-2.2.5-27.i386.rpm  glibc-devel-2.2.5-27.i386.rpm        
nscd-2.2.5-27.i386.rpm
glibc-debug-2.2.5-27.i386.rpm   glibc-profile-2.2.5-27.i386.rpm
[root@localhost i386]# rpm -Fvh  *2.2.5*
Preparing...                ########################################### [100%]
   1:glibc-common           ########################################### [ 20%]
   2:glibc                  warning: /usr/lib/gconv/gconv-modules created as
/usr/lib/gconv/gconv-modules.rpmnew
########################################### [ 40%]
/usr/sbin/iconvconfig: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found
(required by /lib/i686/libc.so.6)
/usr/sbin/iconvconfig: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found
(required by /lib/i686/libc.so.6)
/usr/sbin/iconvconfig: /lib/ld-linux.so.2: version `GLIBC_2.2' not found
(required by /lib/i686/libc.so.6)
error: execution of %post scriptlet from glibc-2.2.5-27 failed, exit status 1
/bin/sh: /lib/i686/libc.so.6: version `GLIBC_PRIVATE' not found (required by
/lib/libdl.so.2)
/bin/sh: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found (required by
/lib/i686/libc.so.6)
/bin/sh: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found (required by
/lib/i686/libc.so.6)
/bin/sh: /lib/ld-linux.so.2: version `GLIBC_2.2' not found (required by
/lib/i686/libc.so.6)
error: execution of %pre scriptlet from glibc-devel-2.2.5-27 failed, exit status
1
error:   install: %pre scriptlet failed (2), skipping glibc-devel-2.2.5-27
   3:glibc-profile          ########################################### [ 60%]
/bin/sh: /lib/i686/libc.so.6: version `GLIBC_PRIVATE' not found (required by
/lib/libdl.so.2)
/bin/sh: /lib/ld-linux.so.2: version `GLIBC_2.1.1' not found (required by
/lib/i686/libc.so.6)
/bin/sh: /lib/ld-linux.so.2: version `GLIBC_2.2.3' not found (required by
/lib/i686/libc.so.6)
/bin/sh: /lib/ld-linux.so.2: version `GLIBC_2.2' not found (required by
/lib/i686/libc.so.6)
error: execution of %pre scriptlet from nscd-2.2.5-27 failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping nscd-2.2.5-27


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Jakub Jelinek 2002-04-05 14:02:37 UTC
Well, the main problem is that you are overriding i686 glibc with i386 one.
Generally there shouldn't be any reason to do that, plus there is some rpm
bug which causes /lib/i686 directory not to be removed.
I added some code to remove the files in glibc-2.2.5-25.i386.rpm, but they
were removing only the same version, not any older version, so i686 -> i386
"upgrades" would work e.g. from glibc-2.2.5-25 to glibc-2.2.5-30, but not
glibc-2.2.4-xx to gilbc-2.2.5-yy.
Should be fixed in glibc-2.2.5-31, but I'd suggest you to install the correct
architecture instead.

Comment 2 Andrew Schultz 2002-05-03 18:09:06 UTC
I got the same messages (to the best of my memory) upgrading (Alpha) from
glibc-2.2.4-24 to glibc-2.2.5-34.  I think it also complained about ld-linux.so
and libc.so being "truncated".

The problem was that libc.so.6.1 was still linked to libc.2.2.4.so.  Linking it
to libc.2.2.5.so instead fixed everything.  All the other libs were properly linked.

We had similar problems upgrading from RH 7.0 to 7.1, although I think the
problem there was sometimes ld-linux.so.2 being linked to the old (non-existent)
2.1 lib.


Note You need to log in before you can comment on or make changes to this bug.