Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 616359 - virt-install: rhel 3u9 guest was detected as rhel4 variant
virt-install: rhel 3u9 guest was detected as rhel4 variant
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: RHELNAK
: 630557 (view as bug list)
Depends On:
Blocks: 704468
  Show dependency treegraph
 
Reported: 2010-07-20 05:10 EDT by Wayne Sun
Modified: 2011-05-19 09:45 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This change reports to the user the correct variant of Red Hat Enterprise Linux 3 Update 9 guest when it is detected as the previous version would report Red Hat Enterprise Linux 4.
Story Points: ---
Clone Of:
: 704468 (view as bug list)
Environment:
Last Closed: 2011-05-19 09:45:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0636 normal SHIPPED_LIVE python-virtinst bug fix and enhancement update 2011-05-18 13:55:48 EDT

  None (edit)
Description Wayne Sun 2010-07-20 05:10:42 EDT
Description of problem:
when install a rhel3u9-i386 guest, the guest was detected as rhel4 variant. It would not impact the guest installation anyway.
Debug info:
Tue, 20 Jul 2010 14:39:06 DEBUG    Auto detected OS type as: linux
Tue, 20 Jul 2010 14:39:06 DEBUG    Auto detected OS variant as: rhel4

Version-Release number of selected component (if applicable):
kernel: 2.6.32-50.el6.x86_64
libvirt-0.8.1-15.el6.x86_64
python-virtinst-0.500.3-5.el6.noarch
qemu-kvm-0.12.1.2-2.96.el6.x86_64
qemu-img-0.12.1.2-2.96.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1.virt-install --name rhel3u9_i386 --ram 512 --vcpus=1 --disk path=/var/lib/libvirt/images/rhel3u9_i386.img,size=8 --network network:default --accelerate --vnc --mac=52:54:00:e0:04:2d --location http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/ --extra-args ks=http://home.englab.nay.redhat.com/~nzhang/http/ks-rhel3u9-i386.cfg --noreboot --debug

2.
3.
  
Actual results:
guest was detected as wrong variant

Expected results:
guest was detected as right variant

Additional info:
/usr/sbin/virt-install --name rhel3u9_i386 --ram 512 --vcpus=1 --disk path=/var/lib/libvirt/images/rhel3u9_i386.img,size=8 --network network:default --accelerate --vnc --mac=52:54:00:e0:04:2d --location http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/ --extra-args ks=http://home.englab.nay.redhat.com/~nzhang/http/ks-rhel3u9-i386.cfg --noreboot --debug
Tue, 20 Jul 2010 14:39:02 DEBUG    Requesting libvirt URI default
Tue, 20 Jul 2010 14:39:02 DEBUG    Received libvirt URI qemu:///system
Tue, 20 Jul 2010 14:39:02 DEBUG    Requesting virt method \'default\', hv type \'default\'.
Tue, 20 Jul 2010 14:39:02 DEBUG    Received virt method \'hvm\'
Tue, 20 Jul 2010 14:39:02 DEBUG    Hypervisor name is \'kvm\'
Tue, 20 Jul 2010 14:39:02 DEBUG    parse_disk: returning {\'format\': None, \'bus\': None, \'readOnly\': False, \'volInstall\': None, \'path\': \'/var/lib/libvirt/images/rhel3u9_i386.img\', \'device\': \'disk\', \'volName\': None, \'conn\': <libvirt.virConnect instance at 0x1ac08c0>, \'size\': 8.0, \'driverCache\': None, \'shareable\': False, \'sparse\': True}
Tue, 20 Jul 2010 14:39:02 DEBUG    Path \'/var/lib/libvirt/images\' is target for pool \'default\'. Creating volume \'rhel3u9_i386.img\'.
Tue, 20 Jul 2010 14:39:02 DEBUG    DistroInstaller location is a network source.
Tue, 20 Jul 2010 14:39:02 DEBUG    Attempting to detect distro:
Tue, 20 Jul 2010 14:39:02 DEBUG    HTTP hasFile: didn\'t find http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/.treeinfo
Tue, 20 Jul 2010 14:39:02 DEBUG    HTTP hasFile: didn\'t find http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/Fedora
Tue, 20 Jul 2010 14:39:02 DEBUG    HTTP hasFile: didn\'t find http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/Server
Tue, 20 Jul 2010 14:39:02 DEBUG    HTTP hasFile: didn\'t find http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/Client
Tue, 20 Jul 2010 14:39:06 DEBUG    Detected a RHEL 4 distro
Tue, 20 Jul 2010 14:39:06 DEBUG    Fetching URI: http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/images/pxeboot/vmlinuz
Tue, 20 Jul 2010 14:39:06 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-vmlinuz.JPKcXO

Retrieving file vmlinuz...                               | 1.7 MB     00:00 ... 
Tue, 20 Jul 2010 14:39:06 DEBUG    Fetching URI: http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/images/pxeboot/initrd.img
Tue, 20 Jul 2010 14:39:06 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-initrd.img.mspqfb

Retrieving file initrd.img...                            | 5.4 MB     00:00 ... 
Tue, 20 Jul 2010 14:39:06 DEBUG    Auto detected OS type as: linux
Tue, 20 Jul 2010 14:39:06 DEBUG    Auto detected OS variant as: rhel4
Tue, 20 Jul 2010 14:39:06 DEBUG    Creating storage volume \'rhel3u9_i386.img\' with xml:
<volume>
  <name>rhel3u9_i386.img</name>
  <capacity>8589934592</capacity>
  <allocation>0</allocation>
  <target>
    <format type=\'raw\'/>
  </target>
</volume>


Allocating \'rhel3u9_i386.img\'                            | 8.0 GB     00:00     
Tue, 20 Jul 2010 14:39:06 DEBUG    Storage volume \'rhel3u9_i386.img\' install complete.
Tue, 20 Jul 2010 14:39:06 DEBUG    Can\'t fix selinux context in this case.
Tue, 20 Jul 2010 14:39:06 DEBUG    Generated install XML: 
<domain type=\'kvm\'>
  <name>rhel3u9_i386</name>
  <currentMemory>524288</currentMemory>
  <memory>524288</memory>
  <uuid>8841e7f1-b688-486b-cc81-106577134b40</uuid>
  <os>
    <type arch=\'x86_64\'>hvm</type>
    <kernel>/var/lib/libvirt/boot/virtinst-vmlinuz.JPKcXO</kernel>
    <initrd>/var/lib/libvirt/boot/virtinst-initrd.img.mspqfb</initrd>
    <cmdline>method=http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/ ks=http://home.englab.nay.redhat.com/~nzhang/http/ks-rhel3u9-i386.cfg</cmdline>
  </os>
  <features>
    <acpi/><apic/><pae/>
  </features>
  <clock offset="utc"/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <vcpu>1</vcpu>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type=\'file\' device=\'disk\'>
      <driver name=\'qemu\' type=\'raw\' cache=\'none\'/>
      <source file=\'/var/lib/libvirt/images/rhel3u9_i386.img\'/>
      <target dev=\'hda\' bus=\'ide\'/>
    </disk>
    <interface type=\'network\'>
      <source network=\'default\'/>
      <mac address=\'52:54:00:e0:04:2d\'/>
    </interface>
    <input type=\'mouse\' bus=\'ps2\'/>
    <graphics type=\'vnc\' port=\'-1\' keymap=\'en-us\'/>
    <console type=\'pty\'/>
    <video>
      <model type=\'cirrus\'/>
    </video>
  </devices>
</domain>

Tue, 20 Jul 2010 14:39:06 DEBUG    Couldn\'t lookup storage volume in prog thread.

Creating domain...                                       |    0 B     00:00     
Tue, 20 Jul 2010 14:39:06 DEBUG    Started guest, looking to see if it is running
Tue, 20 Jul 2010 14:39:06 DEBUG    Launching console callback
Tue, 20 Jul 2010 14:39:06 DEBUG    Generated boot XML: 
<domain type=\'kvm\'>
  <name>rhel3u9_i386</name>
  <currentMemory>524288</currentMemory>
  <memory>524288</memory>
  <uuid>8841e7f1-b688-486b-cc81-106577134b40</uuid>
  <os>
    <type arch=\'x86_64\'>hvm</type>
    <boot dev=\'hd\'/>
  </os>
  <features>
    <acpi/><apic/><pae/>
  </features>
  <clock offset="utc"/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <vcpu>1</vcpu>
  <devices>
    <emulator>/usr/libexec/qemu-kvm</emulator>
    <disk type=\'file\' device=\'disk\'>
      <driver name=\'qemu\' type=\'raw\' cache=\'none\'/>
      <source file=\'/var/lib/libvirt/images/rhel3u9_i386.img\'/>
      <target dev=\'hda\' bus=\'ide\'/>
    </disk>
    <interface type=\'network\'>
      <source network=\'default\'/>
      <mac address=\'52:54:00:e0:04:2d\'/>
    </interface>
    <input type=\'mouse\' bus=\'ps2\'/>
    <graphics type=\'vnc\' port=\'-1\' keymap=\'en-us\'/>
    <console type=\'pty\'/>
    <video>
      <model type=\'cirrus\'/>
    </video>
  </devices>
</domain>

Cannot open display: 
Run \'virt-viewer --help\' to see a full list of available command line options
Tue, 20 Jul 2010 14:39:08 DEBUG    Removing /var/lib/libvirt/boot/virtinst-vmlinuz.JPKcXO
Tue, 20 Jul 2010 14:39:08 DEBUG    Removing /var/lib/libvirt/boot/virtinst-initrd.img.mspqfb
Tue, 20 Jul 2010 14:39:10 DEBUG    Domain state after install: 1
Comment 2 RHEL Product and Program Management 2010-07-20 05:37:59 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Cole Robinson 2010-08-06 14:01:53 EDT
Since this doesn't really have any functional affect, just deferring to 6.1
Comment 4 Cole Robinson 2010-08-23 16:40:16 EDT
Fixed now upstream:

http://hg.fedorahosted.org/hg/python-virtinst/rev/a0ef2e5c44d2
Comment 5 Cole Robinson 2010-09-09 10:26:36 EDT
*** Bug 630557 has been marked as a duplicate of this bug. ***
Comment 7 Cole Robinson 2011-01-14 17:09:54 EST
Fix built in python-virtinst-0.500.5-1.el6
Comment 9 koka xiong 2011-01-19 03:52:10 EST
Verified with python-virtinst-0.500.5-1.el6
1.Run virt-install --name rhel3u9_i386 --ram 512 --vcpus=1 --disk
path=/var/lib/libvirt/images/rhel3u9_i386.img,size=8 --network network:default
--accelerate --vnc --mac=52:54:00:e0:04:2d --location
http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/
--extra-args
ks=http://home.englab.nay.redhat.com/~nzhang/http/ks-rhel3u9-i386.cfg
--noreboot --debug
2.It detected as a rhel3 variant
Tue, 18 Jan 2011 14:12:11 DEBUG    Detected a rhel3 distro
Tue, 18 Jan 2011 14:12:11 DEBUG    Guest.has_install_phase: True

Starting install...
Tue, 18 Jan 2011 14:12:11 DEBUG    Attempting to detect distro:
Tue, 18 Jan 2011 14:12:11 DEBUG    HTTP hasFile: didn't find http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/.treeinfo
Tue, 18 Jan 2011 14:12:11 DEBUG    HTTP hasFile: didn't find http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/Fedora
Tue, 18 Jan 2011 14:12:11 DEBUG    HTTP hasFile: didn't find http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/Server
Tue, 18 Jan 2011 14:12:11 DEBUG    HTTP hasFile: didn't find http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/Client
Tue, 18 Jan 2011 14:12:11 DEBUG    Detected a rhel3 distro
Tue, 18 Jan 2011 14:12:11 DEBUG    Fetching URI: http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/images/pxeboot/vmlinuz
Tue, 18 Jan 2011 14:12:11 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-vmlinuz.LURIi_
Retrieving file vmlinuz...                                                              | 1.7 MB     00:00 ... 
Tue, 18 Jan 2011 14:12:11 DEBUG    Fetching URI: http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-3/U9/AS/i386/tree/images/pxeboot/initrd.img
Tue, 18 Jan 2011 14:12:11 DEBUG    Saved file to /var/lib/libvirt/boot/virtinst-initrd.img.AEODeW
Retrieving file initrd.img...                                                           | 5.4 MB     00:00 ... 
Tue, 18 Jan 2011 14:12:11 DEBUG    Auto detected OS type as: linux
Tue, 18 Jan 2011 14:12:11 DEBUG    Auto detected OS variant as: rhel3
Tue, 18 Jan 2011 14:12:12 DEBUG    Generated install XML:
Comment 10 zhe peng 2011-04-15 06:11:44 EDT
verified this bug with:
Linux localhost.localdomain 2.6.32-130.el6.x86_64 #1 SMP Tue Apr 5 19:58:31 EDT
2011 x86_64 x86_64 x86_64 GNU/Linux

python-virtinst-0.500.5-3.el6.noarch
libvirt-0.8.7-17.el6.x86_64

passed.
Comment 12 Michael Hideo 2011-05-12 20:26:38 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
* This change reports to the user the correct variant of Red Hat Enterprise Linux 3 Update 9 guest when it is detected as the previous version would report Red Hat Enterprise Linux 4.  (BZ#616359)
Comment 13 Michael Hideo 2011-05-16 17:43:47 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-* This change reports to the user the correct variant of Red Hat Enterprise Linux 3 Update 9 guest when it is detected as the previous version would report Red Hat Enterprise Linux 4.  (BZ#616359)+This change reports to the user the correct variant of Red Hat Enterprise Linux 3 Update 9 guest when it is detected as the previous version would report Red Hat Enterprise Linux 4.
Comment 14 errata-xmlrpc 2011-05-19 09:45:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0636.html

Note You need to log in before you can comment on or make changes to this bug.