Bug 616367 - luci_admin Error Message Inconsistent (when zope is not installed)
luci_admin Error Message Inconsistent (when zope is not installed)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.5
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 05:25 EDT by James Hammett
Modified: 2011-02-08 09:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-08 09:45:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hammett 2010-07-20 05:25:17 EDT
Description of problem:
If one runs Luci, without using root permission.  If Zope is not installed it produces a python error.

If Zope is installed, the error indicates the program needs to be run as root.


Version-Release number of selected component (if applicable):
0.12.2

How reproducible:
Always

Steps to Reproduce:
1.$ /usr/sbin/luci_admin 
2.
3.
  
Actual results:
Traceback (most recent call last):
  File "/usr/sbin/luci_admin", line 33, in ?
    from Products import __path__
ImportError: No module named Products

Expected results:
         Only the 'root' user can run /usr/sbin/luci_admin
           Try again with root privileges.

Additional info:
Not a major problem, but I was trying to diagnose a problem with python and when I figured out Zope was missing and got a Valid Error message I said "DOOH!".

thanks,
James
Comment 1 Ryan McCabe 2010-07-20 11:12:07 EDT
How did you manage to not have the zope bits installed but luci installed?
Comment 2 James Hammett 2010-08-01 00:50:24 EDT
Didn't install the cluster stuff during the install, but instead used:
         yum groupinstall cluster

(Machine was originally installed as workstation, NOT server).

thanks,
James

(Not in the office today to look over the machine).
Comment 3 James Hammett 2010-08-01 00:54:43 EDT
Or I MAY have done:
               yum install luci

(ISince the machine was going to be simply managing the cluster nodes and not actually part of it).

One thing I remember from the install was that there was only 1 dependency (and it wasn't Zope).

thanks,
James
Comment 4 RHEL Product and Program Management 2011-02-08 09:45:14 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.