Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 616368 - RHEL 5.5 guest hang while install process in RHEL6.0 host
RHEL 5.5 guest hang while install process in RHEL6.0 host
Status: CLOSED DUPLICATE of bug 607443
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 05:27 EDT by Joy Pu
Modified: 2010-11-11 14:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 12:41:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Whole trace log for guest hang (12.02 MB, application/octet-stream)
2010-07-20 05:30 EDT, Joy Pu
no flags Details
Screen of hang guest (51.54 KB, image/jpeg)
2010-07-20 06:02 EDT, Joy Pu
no flags Details

  None (edit)
Description Joy Pu 2010-07-20 05:27:30 EDT
Description:
In the RHEL6.0 host, the process of install RHEL 5.5 guest will hang while installing packages. This will happen both in single vcpu or multi vcpu.
Version-Release number of selected component (if applicable):
host kernel: 2.6.32-50.el6.x86_64  
guest kernel: 2.6.18-194.el5.x86_64

# rpm -qa |grep qemu
qemu-kvm-tools-0.12.1.2-2.96.el6.x86_64
qemu-kvm-0.12.1.2-2.96.el6.x86_64
qemu-kvm-debuginfo-0.12.1.2-2.96.el6.x86_64
gpxe-roms-qemu-0.9.7-6.3.el6.noarch
qemu-img-0.12.1.2-2.96.el6.x86_64


How reproducible:
1 out of 3

Steps to Reproduce:
1. Create image by qemu-img
# qemu-img create -f qcow2 /root/autotest/client/tests/kvm/images/RHEL-Server-5.5-64-virtio.qcow2 15G
2. Install guest with CDROM using following cmd:
# /root/autotest/client/tests/kvm/qemu -name vm1 -monitor unix:/tmp/monitor-humanmonitor1-20100720-150956-huBw,server,nowait -drive file=/root/autotest/client/tests/kvm/isos/linux/RHEL-Server-5.5-x86_64-DVD.iso,if=none,id=drive-ide0-0-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -serial unix:/tmp/serial-20100720-150956-huBw,server,nowait -drive file=/root/autotest/client/tests/kvm/images/RHEL-Server-5.5-64-virtio.qcow2,if=none,id=drive-ide0-0-1,media=disk,cache=none,format=qcow2 -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -net nic,vlan=0,netdev=idI7cw7z,model=virtio,macaddr=02:30:0D:20:44:49 -netdev user,id=idI7cw7z,tftp=/root/autotest/client/tests/kvm/images/tftpboot,hostfwd=tcp::5000-:22,hostfwd=tcp::5001-:12323 -m 4096 -smp 1 -fda /root/autotest/client/tests/kvm/images/floppy.img -vnc :0 -spice port=8000,disable-ticketing -vga qxl -rtc base=utc,clock=host -M rhel6.0.0 -usbdevice tablet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -bootp /pxelinux.0 -boot n
3. Wait until the system hang. Trace kvm with debugfs and get kvm statues from command "kvm_stat"

Actual results:
The process of RHEL 5.5 install will hang.

Expected results:
Can complete the process of installation for RHEL 5.5

Additional info:
1. The command line:
# /root/autotest/client/tests/kvm/qemu -name vm1 -monitor unix:/tmp/monitor-humanmonitor1-20100720-150956-huBw,server,nowait -drive file=/root/autotest/client/tests/kvm/isos/linux/RHEL-Server-5.5-x86_64-DVD.iso,if=none,id=drive-ide0-0-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -serial unix:/tmp/serial-20100720-150956-huBw,server,nowait -drive file=/root/autotest/client/tests/kvm/images/RHEL-Server-5.5-64-virtio.qcow2,if=none,id=drive-ide0-0-1,media=disk,cache=none,format=qcow2 -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -net nic,vlan=0,netdev=idI7cw7z,model=virtio,macaddr=02:30:0D:20:44:49 -netdev user,id=idI7cw7z,tftp=/root/autotest/client/tests/kvm/images/tftpboot,hostfwd=tcp::5000-:22,hostfwd=tcp::5001-:12323 -m 4096 -smp 1 -fda /root/autotest/client/tests/kvm/images/floppy.img -vnc :0 -spice port=8000,disable-ticketing -vga qxl -rtc base=utc,clock=host -M rhel6.0.0 -usbdevice tablet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -bootp /pxelinux.0 -boot n

2.Host cpuinfo
processor       : 2
vendor_id       : AuthenticAMD
cpu family      : 16
model           : 2
model name      : AMD Phenom(tm) 8750 Triple-Core Processor
stepping        : 3
cpu MHz         : 1200.000
cache size      : 512 KB
physical id     : 0
siblings        : 3
core id         : 2
cpu cores       : 3
apicid          : 2
initial apicid  : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs npt lbrv svm_lock
bogomips        : 4809.88
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate


3. KVM status info:
3.1
#  kvm_stat -1
efer_reload                    0         0
exits                    9545062         0
fpu_reload               1300856         0
halt_exits                349203         0
halt_wakeup               175518         0
host_state_reload        1302177         0
hypercalls                     0         0
insn_emulation            900623         0
insn_emulation_fail            0         0
invlpg                         0         0
io_exits                 7918007         0
irq_exits                 338852         0
irq_injections            559124         0
irq_window                     0         0
largepages                  1554         0
mmio_exits                137200         0
mmu_cache_miss               165         0
mmu_flooded                    0         0
mmu_pde_zapped                 0         0
mmu_pte_updated                0         0
mmu_pte_write              76960         0
mmu_recycled                   0         0
mmu_shadow_zapped            130         0
mmu_unsync                     0         0
nmi_injections                 0         0
nmi_window                     0         0
pf_fixed                    2494         0
pf_guest                       0         0
remote_tlb_flush               3         0
request_irq                    0         0
signal_exits                   4         0
tlb_flush                      0         0

3.2 debugfs info:
# ps -aux
root     18159 10.4 30.3 4602788 1169484 pts/4 Sl+  16:17   2:14 /root/autotest/client/tests/kvm/qemu -name vm1 -monitor unix:/tmp/monitor-humanmonitor1-20100720-150956-huBw,server,nowait -drive file=/root/autotest/client/tests/kvm/isos/linux/RHEL-Server-5.5-x86_64-DVD.iso,if=none,id=drive-ide0-0-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -serial unix:/tmp/serial-20100720-150956-huBw,server,nowait -drive file=/root/autotest/client/tests/kvm/images/RHEL-Server-5.5-64-virtio.qcow2,if=none,id=drive-ide0-0-1,media=disk,cache=none,format=qcow2 -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -net nic,vlan=0,netdev=idI7cw7z,model=virtio,macaddr=02:30:0D:20:44:49 -netdev user,id=idI7cw7z,tftp=/root/autotest/client/tests/kvm/images/tftpboot,hostfwd=tcp::5000-:22,hostfwd=tcp::5001-:12323 -m 4096 -smp 1 -fda /root/autotest/client/tests/kvm/images/floppy.img -vnc :0 -spice port=8000,disable-ticketing -vga qxl -rtc base=utc,clock=host -M rhel6.0.0 -usbdevice tablet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -bootp /pxelinux.0 -boot n
root     18160  0.2  0.0      0     0 ?        S    16:17   0:03 [kvm-pit-wq]

# debugfs tracing kvm info will repeat this:
           <...>-18161 [001] 18551.265812: kvm_inj_virq: irq 49
           <...>-18161 [001] 18551.265813: kvm_entry: vcpu 0
           <...>-18161 [001] 18551.265816: kvm_exit: reason npf rip 0xffffffff8007a3bc
           <...>-18161 [001] 18551.265817: kvm_page_fault: address fee000b0 error_code 6
           <...>-18161 [001] 18551.265822: kvm_mmio: mmio write len 4 gpa 0xfee000b0 val 0x0
           <...>-18161 [001] 18551.265823: kvm_apic: apic_write APIC_EOI = 0x0
           <...>-18161 [001] 18551.265824: kvm_ack_irq: irqchip IOAPIC pin 2
           <...>-18161 [001] 18551.265825: kvm_entry: vcpu 0
           <...>-18161 [001] 18551.265960: kvm_exit: reason interrupt rip 0x2b936554d90b
           <...>-18161 [001] 18551.265961: kvm_entry: vcpu 0
           <...>-18161 [001] 18551.266337: kvm_exit: reason interrupt rip 0x2b936251602d
           <...>-18161 [001] 18551.266338: kvm_apic_accept_irq: apicid 0 vec 239 (Fixed|edge)
           <...>-18161 [001] 18551.266339: kvm_inj_virq: irq 239
           <...>-18161 [001] 18551.266339: kvm_entry: vcpu 0
           <...>-18161 [001] 18551.266341: kvm_exit: reason npf rip 0xffffffff800791f7
           <...>-18161 [001] 18551.266342: kvm_page_fault: address fee000b0 error_code 6
           <...>-18161 [001] 18551.266345: kvm_mmio: mmio write len 4 gpa 0xfee000b0 val 0x0
           <...>-18161 [001] 18551.266345: kvm_apic: apic_write APIC_EOI = 0x0
           <...>-18161 [001] 18551.266346: kvm_entry: vcpu 0
           <...>-18161 [001] 18551.266528: kvm_exit: reason io rip 0xffffffff8017258c
           <...>-18161 [001] 18551.266529: kvm_pio: pio_write at 0x3d4 size 2 count 1
           <...>-18160 [000] 18551.266797: kvm_set_irq: gsi 0 level 1 source 1
           <...>-18160 [000] 18551.266803: kvm_pic_set_irq: chip 0 pin 0 (edge|masked)
           <...>-18160 [000] 18551.266807: kvm_apic_accept_irq: apicid 0 vec 49 (Fixed|edge)
           <...>-18160 [000] 18551.266808: kvm_ioapic_set_irq: pin 2 dst 0 vec=49 (Fixed|physical|edge)
           <...>-18160 [000] 18551.266809: kvm_set_irq: gsi 0 level 0 source 1
           <...>-18160 [000] 18551.266809: kvm_pic_set_irq: chip 0 pin 0 (edge|masked)
           <...>-18160 [000] 18551.266810: kvm_ioapic_set_irq: pin 2 dst 0 vec=49 (Fixed|physical|edge)
Comment 1 Joy Pu 2010-07-20 05:30:56 EDT
Created attachment 433111 [details]
Whole trace log for guest hang
Comment 4 Joy Pu 2010-07-20 06:02:46 EDT
Created attachment 433117 [details]
Screen of hang guest
Comment 5 Qian Cai 2010-07-20 12:41:16 EDT

*** This bug has been marked as a duplicate of bug 607443 ***

Note You need to log in before you can comment on or make changes to this bug.