Bug 616370 - "pwck -s" and "grpck -s" fail
"pwck -s" and "grpck -s" fail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
: Regression
Depends On: 586322
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 05:29 EDT by Peter Vrabec
Modified: 2010-07-22 22:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: shadow-utils-4.1.4.2-8.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 586322
Environment:
Last Closed: 2010-07-22 22:43:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2010-07-20 05:29:46 EDT
+++ This bug was initially created as a clone of Bug #586322 +++

Description of problem:

Running "pwck -s" and "grpck -s" on the public
RHEL6 beta fails. Both commands just hang and do not
complete.

regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from sgrubb@redhat.com on 2010-07-19 10:16:25 EDT ---

Investigation into this bug reveals that it has a nasty side effect. What causes the hang is that it doesn't match the nfsnobody entry and loops continually. It depends on the order or accounts in the passwd file as to whether or not you hang. If you do not hang, the nasty side effect is that it DELETES one record from your passwd file without prompting. If you run this a few times, it will surely delete your login account from the passwd file and you cannot get back in the machine. It would appear that the cause of the problem is the first chunk of the shadow-4.1.4.2-fixes patch which affects the sorting of passwd records during matching.
Comment 1 Fedora Update System 2010-07-20 05:36:07 EDT
shadow-utils-4.1.4.2-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/shadow-utils-4.1.4.2-8.fc13
Comment 2 Fedora Update System 2010-07-22 22:43:32 EDT
shadow-utils-4.1.4.2-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.