Bug 616381 - qdiskd autoconfig doesn´t like one node cluster corner case
Summary: qdiskd autoconfig doesn´t like one node cluster corner case
Status: CLOSED DUPLICATE of bug 606989
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-20 10:16 UTC by Fabio Massimo Di Nitto
Modified: 2010-07-21 08:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 08:17:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fabio Massimo Di Nitto 2010-07-20 10:16:56 UTC
testing luci removal of nodes feature in a 2 nodes cluster + qdiskd:

remove node 2:

Message from syslogd@rhel6-node1 at Jul 20 12:09:49 ...
 rgmanager[4151]: #1: Quorum Dissolved

left me a bit puzzled because qdisk is running but:


[root@rhel6-node1 ~]# cman_tool status
Version: 6.2.0
Config Version: 5
Cluster Name: fabbione
Cluster Id: 17126
Cluster Member: Yes
Cluster Generation: 20
Membership state: Cluster-Member
Nodes: 1
Expected votes: 1
Quorum device votes: 0
Total votes: 1
Node votes: 1
Quorum: 2 Activity blocked

it looks like qdiskd is voting 0 _probably_ because of the autovote calculation.

Comment 1 Lon Hohberger 2010-07-20 14:06:56 UTC
That sounds accurate.

Comment 3 Fabio Massimo Di Nitto 2010-07-21 08:17:33 UTC

*** This bug has been marked as a duplicate of bug 606989 ***


Note You need to log in before you can comment on or make changes to this bug.