Bug 61639 - Ksysv sigsegv on exit
Summary: Ksysv sigsegv on exit
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdeutils (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Beth Uptagrafft
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-22 14:35 UTC by harry.heinisch
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 16:40:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description harry.heinisch 2002-03-22 14:35:51 UTC
Description of Problem:

KSysVt editor crashs on exit. 


Version-Release number of selected component (if applicable):

SysV- v1.3.8 

How Reproducible: 

Almost always.

Steps to Reproduce:
1. execute /usr/bin/ksysv  (from console or from menu on gui)
2. make some trivial change (or not)
3. Quuit (if you've made no change) exit (if you have)

Actual Results:

it crashs with signal 11 (SIGSEGV)


Expected Results: graceful exit.


Additional Information:

from the backtrace:

(no debugging symbols found)...0x20001695140 in wait4@@GLIBC_2.1 ()
   from /lib/libc.so.6.1
#0  0x20001695140 in wait4@@GLIBC_2.1 () from /lib/libc.so.6.1
#1  0x200016950ac in __libc_waitpid (pid=16296, stat_loc=0x0, options=0)
    at ../sysdeps/unix/sysv/linux/waitpid.c:26


Also - the app appears to work fine - as long as you dont exit - I did not see 
any crashs while making changes, saving changes etc... All testing was done 
with KDE as the GUI,  on multiple platforms.

Phil.sullivan@compaq.com

Comment 1 Phil Copeland 2002-04-29 15:57:14 UTC
(Verified)


Comment 2 Phil Copeland 2002-05-01 20:44:59 UTC
Strictly speaking this tool was replaced by serviceconf which provides the same
functionality

Phil
=--=

Comment 3 Ngo Than 2004-10-26 16:40:17 UTC
ksysv was not included since rhl9. please report the bug to kde
bugzilla directly. Thanks


Note You need to log in before you can comment on or make changes to this bug.