Bug 616418 - ksh users can't see output from scripts in /etc/profile.d/
ksh users can't see output from scripts in /etc/profile.d/
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: setup (Show other bugs)
4.8
All Linux
high Severity high
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
: ZStream
Depends On: 614694
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 08:10 EDT by RHEL Product and Program Management
Modified: 2011-01-05 01:31 EST (History)
9 users (show)

See Also:
Fixed In Version: setup-2.5.37-4.el4_8.1
Doc Type: Bug Fix
Doc Text:
When logging in to an interactive login shell, the contents of the /etc/profile script are executed in order to set up an initial environment. Messages which should have been displayed to the user upon logging in to the Korn shell (ksh) were suppressed due to an internal test to determine whether the shell is a login shell that relied upon the value of the PS1 environment variable having already been set before /etc/profile was executed. However, this environment variable is set in the Korn shell only after /etc/profile is executed, which led to messages never being displayed to Korn shell users. This update provides an alternative test that does not rely on the PS1 variable being set before /etc/profile execution, with the result that messages are properly displayed to users of the Korn shell upon login.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 08:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2010-07-20 08:10:12 EDT
This bug has been copied from bug #614694 and has been proposed
to be backported to 4.8 z-stream (EUS).
Comment 5 Douglas Silas 2010-07-26 10:36:39 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When logging in to an interactive login shell, the contents of the /etc/profile script are executed in order to set up an initial environment. Messages which should have been displayed to the user upon logging in to the Korn shell (ksh) were suppressed due to an internal test to determine whether the shell is a login shell that relied upon the value of the PS1 environment variable having already been set before /etc/profile was executed. However, this environment variable is set in the Korn shell only after /etc/profile is executed, which led to messages never being displayed to Korn shell users. This update provides an alternative test that does not rely on the PS1 variable being set before /etc/profile execution, with the result that messages are properly displayed to users of the Korn shell upon login.
Comment 10 errata-xmlrpc 2010-07-29 08:13:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0573.html

Note You need to log in before you can comment on or make changes to this bug.