Bug 616419 - RHEL6 ddiskit: new templates fail for RHEL6
RHEL6 ddiskit: new templates fail for RHEL6
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: driver-update-program (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jon Masters
CAI Qian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 08:22 EDT by Martin Wilck
Modified: 2010-07-21 13:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 13:14:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
changes made to the ddiskit templates (2.44 KB, patch)
2010-07-20 08:22 EDT, Martin Wilck
no flags Details | Diff

  None (edit)
Description Martin Wilck 2010-07-20 08:22:16 EDT
Created attachment 433145 [details]
changes made to the ddiskit templates

Description of problem:
The latest ddiskit we got (ddiskit-rhel6_sym53c8xx_beta2plus, Jul. 7 2010) contains a tmpl.spec that doesn't work out of the box for RHEL6


Version-Release number of selected component (if applicable):
ddiskit-rhel6_sym53c8xx_beta2plus

How reproducible:
I took the tmpl.spec and tried to adapt it to the sym53c8xx driver in the ddiskit package, just to see what the differences of the generated kmods are

  
Actual results:
I needed to make a few changes in the template outside the explicitly user-modifiable sections. There was one change in kmodtool, too.

Expected results:
Only name/version/release need to be changed


Additional info:
As I already wrote by email - if we can stick with the old spec file template, this is not a major problem.
Comment 1 Martin Wilck 2010-07-20 08:25:37 EDT
The biggest change is that the xen variants are dropped for RHEL6.
The other important change is related to the different paths under /lib/modules which now include the architecture.
Comment 3 RHEL Product and Program Management 2010-07-20 08:57:53 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Jon Masters 2010-07-21 13:06:54 EDT
I'm sorry for the confusion. You should not need to ship your own kmodtool at this point, and the tmpl directory is stale. The example is for the particular SCSI driver, which uses the stock RHEL6 kmodtool script without modification. Can you check the example, and ignore the "tmpl" directory for now since I will make another updated ddiskit that has a fixed template directory.

Jno.
Comment 7 RHEL Product and Program Management 2010-07-21 13:14:39 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 9 Jon Masters 2010-07-21 13:24:01 EDT
Martin - apologies that our automated system closed this bug down because it is not an "approved" item for RHEL6 (since there is no change required in RHEL6). This was not my intention, but it did it anyway, and I am happy to re-open it if my previous response was not clear. What do you think?

Note You need to log in before you can comment on or make changes to this bug.