Bug 616466 - libvirt-qpid only registers one of each class of object to the qpid broker
libvirt-qpid only registers one of each class of object to the qpid broker
Status: CLOSED DUPLICATE of bug 596682
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt-qpid (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Ian Main
Virtualization Bugs
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 10:29 EDT by Michael Solberg
Modified: 2010-07-20 15:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 15:30:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Solberg 2010-07-20 10:29:44 EDT
Description of problem:
The libvirt-qpid service registers only one of each class of object with the qpid broker.

Version-Release number of selected component (if applicable):
libvirt-qpid-0.2.20-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a few domains in libvirt.
2. Start the libvirt-qpid service.
3. Try to list the domains from the AMQP interface.
  
Actual results:
[root@localhost ~]# virsh list --all
 Id Name                 State
----------------------------------
  2 rhel6dev             running
  4 Satellite            running
  - node1                shut off
  - node2                shut off
  - rhel6cluster2        shut off
  - RHEV-M               shut off
  - Solaris              shut off

qpid: list
Summary of Objects by Type:
    Package                 Class         Active  Deleted
    =======================================================
    org.apache.qpid.broker  session       3       0
    com.redhat.libvirt      domain        1       0
    org.apache.qpid.broker  exchange      8       0
    com.redhat.libvirt      pool          1       0
    com.redhat.libvirt      volume        1       0
    org.apache.qpid.broker  system        1       0
    org.apache.qpid.broker  queue         7       0
    org.apache.qpid.broker  vhost         1       0
    org.apache.qpid.broker  binding       22      0
    org.apache.qpid.broker  connection    3       0
    org.apache.qpid.broker  subscription  7       0
    com.redhat.libvirt      node          1       0
    org.apache.qpid.broker  broker        1       0

[msolberg@localhost ~]$ python
>>> from qmf.console import Session
>>> sess = Session()
>>> broker = sess.addBroker('amqp://localhost:5672')
>>> for d in sess.getObjects(_class='domain', _package='com.redhat.libvirt'):
...     d.getProperties()
... 
[(uuid, '10b20724-f57d-526a-8a73-575d95415f07'), (name, 'rhel6cluster2'), (id, -1), (node, 0-1-1-vendor:product:2ebb9a7a-db29-4389-95b7-c0060ce8ca90-com.redhat.libvirt:node:), (state, 'shutoff'), (numVcpus, 1), (active, 'false')]

Expected results:
sess.getObjects(_class='domain', _package='com.redhat.libvirt') should return a list of all domains defined on the system.
Comment 2 RHEL Product and Program Management 2010-07-20 10:58:04 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Ian Main 2010-07-20 15:30:10 EDT
This has already been filed and fixed in libvirt-qpid-0.2.21-3.

Latest in RHEL6 is libvirt-qpid-0.2.22-2, please test with that as a number of bugs have been fixed.

This is a duplicate bug.

*** This bug has been marked as a duplicate of bug 596682 ***

Note You need to log in before you can comment on or make changes to this bug.