Bug 616483 - JBossAS (5.x) Server resource type and its descendant resource types are missing from Managed Resources section of RHQ docs
JBossAS (5.x) Server resource type and its descendant resource types are miss...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Documentation (Show other bugs)
unspecified
All All
urgent Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 10:53 EDT by Ian Springer
Modified: 2013-08-05 20:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 19:52:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2010-07-20 10:53:33 EDT
See http://www.rhq-project.org/display/JOPR2/Managed+Servers.

There is a child page for the JBossAS (4.x) Server type, but not for the 5.x type.
Comment 1 Charles Crouch 2010-07-20 11:05:16 EDT
Ian, can you work with Deon to make sure all of the updated plugin docs are being used in the product documentation
Comment 2 Deon Ballard 2010-07-20 13:44:21 EDT
I don't know if this is related to the docs posted on the RHQ wiki, but the generated plugindocs have the same name for both JBoss AS 4.x and 5.x/6.x plug-ins, so they both output to JBossAS_Server.xml and both have titles of simply "JBossAS Server." Maybe the generated wiki content has the same naming issue, so one version overwrites another when it is published.

Just an idea.
Comment 3 Ian Springer 2010-07-20 16:39:45 EDT
Deon, yep, that's probably what happened. I think in the past, I've just manually renamed one or both of the generated pages - certainly not ideal. It may be easiest just to add a hack to plugindoc along the lines of:

if (typeName.equals("JBossAS Server") { 
  filename += " (" + pluginName + " plugin)"; 
  pageTitle += " (" + pluginName + " plugin)"; 
}
Comment 4 Deon Ballard 2010-12-19 22:39:52 EST
I am reassigning this to Ian just because I don't think anyone wants me to be the one who attempts to hack plugindoc. :)

Note You need to log in before you can comment on or make changes to this bug.