Bug 616493 - eclipse-oprofile : does not adhere to Static Library Packaging Guidelines
eclipse-oprofile : does not adhere to Static Library Packaging Guidelines
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-oprofile (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 11:27 EDT by Michael Schwendt
Modified: 2011-04-15 17:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: eclipse-oprofile-0.6.1-4.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-15 17:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2010-07-20 11:27:05 EDT
eclipse-oprofile-0.6.0-1.fc14.src
is missing
BuildRequires: binutils-static

[...]

https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries_2

If a library you depend on only provides a static version your package can link against it provided that you BuildRequire the *-static subpackage. Packagers in such a situation should be aware that if a shared library becomes available, that you should adjust your package to use the shared library.
Comment 1 Andrew Overholt 2010-07-27 08:44:12 EDT
It looks like binutils now provides -devel and not -static:

http://koji.fedoraproject.org/koji/buildinfo?buildID=180537
Comment 2 Michael Schwendt 2010-07-27 09:08:34 EDT
binutils-devel provides binutils-static with FESCo's permission,
  http://koji.fedoraproject.org/koji/rpminfo?rpmID=2043704
because it still uses ld scripts to link statically.
Comment 4 Michael Schwendt 2011-04-07 12:35:59 EDT
Reopened by: fedora-report-static-batch.py

eclipse-oprofile-0.6.1-2.fc15.src
is missing
BuildRequires: oprofile-static

[...]

https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries_2

If a library you depend on only provides a static version your package can link against it provided that you BuildRequire the *-static subpackage. Packagers in such a situation should be aware that if a shared library becomes available, that you should adjust your package to use the shared library.
Comment 5 Fedora Update System 2011-04-07 16:17:34 EDT
eclipse-oprofile-0.6.1-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/eclipse-oprofile-0.6.1-3.fc15
Comment 6 Fedora Update System 2011-04-08 10:35:36 EDT
eclipse-oprofile-0.6.1-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/eclipse-oprofile-0.6.1-4.fc15
Comment 7 Fedora Update System 2011-04-09 01:28:48 EDT
Package eclipse-oprofile-0.6.1-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-oprofile-0.6.1-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/eclipse-oprofile-0.6.1-4.fc15
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-04-15 17:39:10 EDT
eclipse-oprofile-0.6.1-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.