Bug 616513 - Vaio VPC Z11-X9E/B touchpad not detected during installation
Vaio VPC Z11-X9E/B touchpad not detected during installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 12:58 EDT by Adam Huffman
Modified: 2018-04-11 11:08 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-29 09:13:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log from installer (69.04 KB, text/plain)
2010-07-20 12:58 EDT, Adam Huffman
no flags Details
anaconda.log (4.99 KB, text/plain)
2010-07-20 12:59 EDT, Adam Huffman
no flags Details
syslog from installer (66.67 KB, text/plain)
2010-07-20 12:59 EDT, Adam Huffman
no flags Details
program log from installer (3.61 KB, text/plain)
2010-07-20 13:00 EDT, Adam Huffman
no flags Details
dmesg output after installer X server has started (40.60 KB, text/plain)
2010-07-22 07:55 EDT, Adam Huffman
no flags Details

  None (edit)
Description Adam Huffman 2010-07-20 12:58:46 EDT
Created attachment 433210 [details]
X log from installer

Description of problem:

I tried installing Fedora 13 to a Vaio VPC Z11-X9E/B.

The mouse cursor was inactive throughout the process - perhaps there is a problem in detecting the touchpad?

I used the Vesa X server as the normal one came up with a blank screen.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Huffman 2010-07-20 12:59:19 EDT
Created attachment 433211 [details]
anaconda.log
Comment 2 Adam Huffman 2010-07-20 12:59:47 EDT
Created attachment 433212 [details]
syslog from installer
Comment 3 Adam Huffman 2010-07-20 13:00:18 EDT
Created attachment 433213 [details]
program log from installer
Comment 4 Adam Huffman 2010-07-21 18:33:15 EDT
Based on the guide here:

http://questier.com/2010/04/26/ubuntu-10-4-lucid-lynx-on-sony-vaio-vpcz11x9e/

I added the boot parameter

i8042.nopnp

and then the touchpad worked normally.
Comment 5 Matěj Cepl 2010-07-22 05:48:50 EDT
Could we get output of dmesg command after the Xorg is up and running, please?

Thank you
Comment 6 Adam Huffman 2010-07-22 07:55:11 EDT
I thought that's what 'syslog' contained?  Anyway, dmesg output attached.  I had to switch back to the console as Fedora isn't actually installed yet, in case that makes any difference.
Comment 7 Adam Huffman 2010-07-22 07:55:58 EDT
Created attachment 433677 [details]
dmesg output after installer X server has started
Comment 8 Matěj Cepl 2010-07-22 12:35:35 EDT
In dmesg I have found:

PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice

To the best of my knowledge this is a kernel issue outside of Xorg team reach. Reassigning to kernel component, but very willing to be persuaded otherwise.
Comment 9 Bug Zapper 2011-06-01 09:21:08 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2011-06-29 09:13:25 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.