Bug 61654 - bad kde menus
Summary: bad kde menus
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-22 16:59 UTC by Gene Czarcinski
Modified: 2007-03-27 03:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-22 16:59:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2002-03-22 16:59:44 UTC
fresh custom install of beta3 with kde+gnome+development

kde3 seems to have changed what is used as the text to be displayed for the
"start" menu.

In kde 2.2, the "Name" value in the xxx.desktop file located in
/usr/share/applnk tree was used.

In kde 3, the "Comment" value is used unless there is none and then the "Name"
value is used.

For a number of packages (especially those listed under Games and Editors), the
"Comment" value provides useless information.

For example, all three editors listed have the Comment value of "text editor".

Although minor, this makes program selection very difficult.

Comment 1 Bernhard Rosenkraenzer 2002-03-24 00:33:59 UTC
This was intentional in order to make it easier for new users ("Text Editor" is much 
preferrable over "Kate" or "VIM" for those who don't know their way around the system 
yet). 
 
I've reverted it because many people are complaining, though.

Comment 2 Gene Czarcinski 2002-03-24 12:09:14 UTC
It was not that using "Text Editor" was a bad idea but that with three editors
all saying the same thing, it was had to differentiate.


Note You need to log in before you can comment on or make changes to this bug.