Bug 616558 - Mozilla NSS - delay token auth until needed
Summary: Mozilla NSS - delay token auth until needed
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Vcelak
QA Contact: Ondrej Moriš
URL:
Whiteboard:
Keywords:
Depends On: 616552 644077
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-20 19:14 UTC by Rich Megginson
Modified: 2013-03-04 01:27 UTC (History)
7 users (show)

Fixed In Version: openldap-2.4.23-4.el6
Doc Type: Bug Fix
Doc Text:
- always when using SSL/TLS - OpenLDAP required certificate/key password during initialization when only information about the certificate were neded, not the content - updated code to require password when really needed - OpenLDAP asks for password when certificate key is required
Story Points: ---
Clone Of: 616552
Environment:
Last Closed: 2011-05-19 13:59:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0673 normal SHIPPED_LIVE openldap bug fix and enhancement update 2011-05-18 18:10:44 UTC

Description Rich Megginson 2010-07-20 19:14:15 UTC
+++ This bug was initially created as a clone of Bug #616552 +++

Created an attachment (id=433242)
openldap-2.4.22-initauthtoken.patch

Description of problem:

The code was doing all of the authentications to all of the tokens during the
init phase.  This was causing problems with NSS cert/key clients, prompting for
the cert/key db password, when it isn't needed, since it is only needed to get
private key information.  The patch is to just remove the token authentication
during init.  The code already authenticates to the token when private key
information is needed e.g. running in TLS/SSL server mode, or using client cert
auth.

This patch has been submitted upstream - http://www.openldap.org/its/index.cgi/Incoming?id=6595 ITS 6595

Comment 4 Jan Vcelak 2011-01-13 20:17:21 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
- always when using SSL/TLS
- OpenLDAP required certificate/key password during initialization when only information about the certificate were neded, not the content
- updated code to require password when really needed
- OpenLDAP asks for password when certificate key is required

Comment 7 errata-xmlrpc 2011-05-19 13:59:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0673.html


Note You need to log in before you can comment on or make changes to this bug.