Bug 61658 - stalls on scp download
Summary: stalls on scp download
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-22 17:32 UTC by jonathan baron
Modified: 2007-04-18 16:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 13:46:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jonathan baron 2002-03-22 17:32:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020319

Description of problem:
Downloads with scp often stall, especially when the file is
a mailbox file with attachments in it.  The problem goes away
90% of the time if I use "scp -v" instead of "scp", and using
"scp -qv" is even better.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. try to download with scp
2.
3.

It is reproducable with a file, but I can't predict which
files will cause the problem.


Actual Results:  stall after 25% or so

Expected Results:  complete download



Additional info:

Comment 1 Christian Vogler 2002-03-22 20:35:06 UTC
I also see this problem, between openssh on RedHat 7.2, and a Datafellows SSH2 server on IRIX.

Furthermore, I received reports from a user that using ssh to connect to a CVS server now also stalls.


Comment 2 Christian Vogler 2002-03-27 04:40:47 UTC
I can reproduce the problem 100% with using ssh to pull a remote CVS repository
(i.e., using CVS_RSH=ssh, and using an :ext:<host>:<path> address). The file
in question is approximately 10 MB. CVS *always* stalls at this point, somewhere
between the first 100 and 300K. The exact stalling point seems to be random.
The -q and -v options made no difference.

I tried it with different kernel versions, same problems. I compiled OpenSSH
3.1p1 from source with gcc 2.96 and gcc 3.0.4, same problems. Only compiling
OpenSSH 3.0.2p1 from source made the problems go away.

This makes it look increasingly likely that the cause is a bug in OpenSSH 3.1,
plain and simple. Unfortunately, it is a showstopper type bug for me.


Comment 3 jonathan baron 2002-04-13 12:11:47 UTC
I just installed version 3.1p1-3.i386.rpm, and the problem SEEMS
to be fixed.  At least I could download files that I could not
download yesterday.  Jon Baron


Comment 4 Dimitri Papadopoulos 2002-04-20 12:58:56 UTC
I can also reproduce similar problems:
- I experience frequent stalls when I log from a Red Hat 7.2 + openssh-3.1p1-2
  client into an OpenLinux-2.4-7 + openssh-2.3.0p1-2 server and tunnel Perforce
  (a CVS-like commercial program) and HTTP.
- I havne't seen that when I log from the same Red Hat 7.2 + openssh-3.1p1-2
  client into a Red Hat 7.2 + openssh-3.1p1-2 server and tunnel Perforce.

I am stracing ssh and should be able to provide a stack trace and an strace
trace next time SSH hangs.


Comment 5 Dimitri Papadopoulos 2002-04-23 19:55:53 UTC
I can't produce a stack trace as I don't know how to debug a program with SUID
set. Debugger won't attach to such a process.

I can show strace output though. I don't know how to attach it to this report.
Tell me how to send it if you believe it can help.

I also should be able to provide verbose openssh output if it helps.

This bug could be a duplicate of 40912, or at least it may be related.


Comment 6 Tomas Mraz 2005-02-03 12:52:41 UTC
Please test with the current Fedora Core.

Comment 7 jonathan baron 2005-02-03 13:03:04 UTC
For me this has not been a problem for quite a while (with FC3).
I forgot about it.

Comment 8 Tomas Mraz 2005-02-03 13:46:55 UTC
OK, thanks.



Note You need to log in before you can comment on or make changes to this bug.