Bug 61659 - Host resources not all available via snmp
Summary: Host resources not all available via snmp
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-22 17:53 UTC by James Sheridan
Modified: 2015-03-05 01:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 16:07:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:106 normal SHIPPED_LIVE Updated ucd-snmp packages available 2002-06-04 04:00:00 UTC

Description James Sheridan 2002-03-22 17:53:18 UTC
Description of Problem:

In the last few versions (at least) of ucd-snmp it is not possible to get 
complete host resource information with the product as supplied.

Version-Release number of selected component (if applicable):

most recent is 4.2.3-1.7.2.3

How Reproducible:

Very

Steps to Reproduce:
1. snmpwalk <host-running-ucd-snmp> <community> hrStorage

Actual Results:

Partial or no host resource information.

Expected Results:

Full host details should be reported, including disk partition usage 
information.

Additional Information:
	
This is easily fixed by adding an include in the source.  This include 
percolates the mib configuration directives down to the host_resource 
functions.  Without it, they assume they are not configured and do not act as 
expected.

File: host_res.h
Location: agents/mibgroup/
Line: 86

#include "mib_module_config.h"

Comment 1 Phil Knirsch 2002-04-09 12:52:41 UTC
Fixed due to update to latest 4.2.4 version available via rawhide.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.