Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 616593 - SELinux is preventing /usr/bin/perl "getattr" access on /usr/share/perl5/strict.pm.
SELinux is preventing /usr/bin/perl "getattr" access on /usr/share/perl5...
Status: CLOSED DUPLICATE of bug 616594
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:b9ae4b45c2a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 17:21 EDT by Pierre-YvesChibon
Modified: 2010-07-21 03:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 03:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-YvesChibon 2010-07-20 17:21:10 EDT
Summary:

SELinux is preventing /usr/bin/perl "getattr" access on
/usr/share/perl5/strict.pm.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by iostat. It is not expected that this access
is required by iostat and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:munin_system_plugin_t:s0
Target Context                system_u:object_r:usr_t:s0
Target Objects                /usr/share/perl5/strict.pm [ file ]
Source                        irqstats
Source Path                   /usr/bin/perl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.10.1-114.fc13
Target RPM Packages           perl-5.10.1-114.fc13
Policy RPM                    selinux-policy-3.7.19-33.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.6-147.fc13.i686 #1
                              SMP Tue Jul 6 22:30:55 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Tue 20 Jul 2010 11:18:36 PM CEST
Last Seen                     Tue 20 Jul 2010 11:18:37 PM CEST
Local ID                      715bed36-bed0-44e5-9a41-c35a737ac78a
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1279660717.77:26995): avc:  denied  { getattr } for  pid=12066 comm="iostat" path="/usr/share/perl5/strict.pm" dev=sdb2 ino=10621 scontext=unconfined_u:system_r:munin_system_plugin_t:s0 tcontext=system_u:object_r:usr_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1279660717.77:26995): arch=40000003 syscall=195 success=yes exit=0 a0=998e430 a1=bfd915d0 a2=3dbff4 a3=998e430 items=0 ppid=11943 pid=12066 auid=500 uid=490 gid=477 euid=490 suid=490 fsuid=490 egid=477 sgid=477 fsgid=477 tty=(none) ses=1 comm="iostat" exe="/usr/bin/perl" subj=unconfined_u:system_r:munin_system_plugin_t:s0 key=(null)



Hash String generated from  catchall,irqstats,munin_system_plugin_t,usr_t,file,getattr
audit2allow suggests:

#============= munin_system_plugin_t ==============
allow munin_system_plugin_t usr_t:file getattr;
Comment 1 Miroslav Grepl 2010-07-21 03:06:52 EDT

*** This bug has been marked as a duplicate of bug 616594 ***

Note You need to log in before you can comment on or make changes to this bug.