Bug 616613 - Automatic queue regression between 1.2.2-4.fc13 and 1.2.3-3.fc13
Summary: Automatic queue regression between 1.2.2-4.fc13 and 1.2.3-3.fc13
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-21 00:09 UTC by Jesse Pollard
Modified: 2010-09-27 14:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-27 14:08:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Printing trouble shooting output (24.98 KB, text/plain)
2010-07-21 14:59 UTC, Jesse Pollard
no flags Details
trouble shooting output (60.52 KB, text/plain)
2010-07-28 15:31 UTC, Jesse Pollard
no flags Details
additional trouble report (85.85 KB, text/plain)
2010-07-28 17:28 UTC, Jesse Pollard
no flags Details
testing different printer model (69.64 KB, text/plain)
2010-08-17 23:56 UTC, Jesse Pollard
no flags Details
Another try (185.21 KB, text/plain)
2010-08-18 00:05 UTC, Jesse Pollard
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 608443 None None None Never

Description Jesse Pollard 2010-07-21 00:09:42 UTC
Description of problem:

Office jet G55 worked under Fedora 11 without problems.
Status indicates that the printer queueing (and printing) is enabled.
Yet jobs are never sent, or are discarded.

Version-Release number of selected component (if applicable):


How reproducible:

At the present time, all jobs sent to the printer fail.


Steps to Reproduce:
1. ls -l | lpr
2.  job sits forever
3. Select test page print from System>Administration>Printing
  
Actual results:

No output, no error messages. (one, after about an hour of trying is
"Printer 'OfficeJet-G55' may not be connected". Cable is connected.
USB logs in the messages log show it.

Expected results:

printouts.

Additional info:

USB messages seen in the system log:

Jul 20 19:47:55 localhost kernel: usb 7-1: new full speed USB device using uhci_hcd and address 5
Jul 20 19:47:56 localhost kernel: usb 7-1: New USB device found, idVendor=03f0, idProduct=0011
Jul 20 19:47:56 localhost kernel: usb 7-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jul 20 19:47:56 localhost kernel: usb 7-1: Product: OfficeJet G55
Jul 20 19:47:56 localhost kernel: usb 7-1: Manufacturer: Hewlett-Packa
Jul 20 19:47:56 localhost kernel: usb 7-1: SerialNumber: SGG13E04MKVL
Jul 20 19:47:56 localhost kernel: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 3 vid 0x03F0 pid 0x0011
Jul 20 19:47:57 localhost udev-add-printer: File "/lib/udev/udev-add-printer", line 230, in <module>#012    add_queue (sys.argv[1], sys.argv[2:])
Jul 20 19:47:57 localhost udev-add-printer: File "/lib/udev/udev-add-printer", line 102, in add_queue#012    if id_dict["MFG"].lower () in MFG_BLACKLIST:
Jul 20 19:47:57 localhost udev-add-printer: NameError: global name 'MFG_BLACKLIST' is not defined
Jul 20 19:47:57 localhost udev-configure-printer: invalid or missing IEEE 1284 Device ID
Jul 20 19:47:58 localhost hp[3446]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Jul 20 19:47:58 localhost python: io/hpmud/pp.c 627: unable to read device-id ret=-1
Jul 20 19:48:13 localhost udev-add-printer: File "/lib/udev/udev-add-printer", line 230, in <module>#012    add_queue (sys.argv[1], sys.argv[2:])
Jul 20 19:48:13 localhost udev-add-printer: File "/lib/udev/udev-add-printer", line 102, in add_queue#012    if id_dict["MFG"].lower () in MFG_BLACKLIST:
Jul 20 19:48:13 localhost udev-add-printer: NameError: global name 'MFG_BLACKLIST' is not defined

This appears to be a rather fatal problem in udev-add-printer.

Comment 1 Jiri Popelka 2010-07-21 13:57:26 UTC
Can you also attach output from Printing troubleshooter ? thanks
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter

Comment 2 Tim Waugh 2010-07-21 14:23:24 UTC
Fixed upstream in comment 24c13912dbdc27e104ffc0495100ba259006c435.

Comment 3 Jesse Pollard 2010-07-21 14:59:32 UTC
Created attachment 433442 [details]
Printing trouble shooting output

Here it is... Apologies for forgetting this.

The only thing I've been able to find (as far as errors go) was the udev reports
in /var/log/messages file (already included).

Comment 4 Jesse Pollard 2010-07-27 13:55:16 UTC
I've checked the commit# 24c13912dbdc27e104ffc0495100ba259006c435.

It fixes one bug, but uncovers another error (from /var/log/messages):

Jul 27 09:38:55 localhost kernel: usb 7-1: new full speed USB device using uhci_hcd and address 5
Jul 27 09:38:55 localhost kernel: usb 7-1: New USB device found, idVendor=03f0, idProduct=0011
Jul 27 09:38:55 localhost kernel: usb 7-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jul 27 09:38:55 localhost kernel: usb 7-1: Product: OfficeJet G55
Jul 27 09:38:55 localhost kernel: usb 7-1: Manufacturer: Hewlett-Packa
Jul 27 09:38:55 localhost kernel: usb 7-1: SerialNumber: SGG13E04MKVL
Jul 27 09:38:56 localhost kernel: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 3 vid 0x03F0 pid 0x0011
Jul 27 09:38:56 localhost udev-configure-printer: invalid or missing IEEE 1284 Device ID

Comment 5 Tim Waugh 2010-07-28 09:48:57 UTC
That message is harmless actually.  Does the printer queue get added?  If so all is working fine.

Comment 6 Jesse Pollard 2010-07-28 11:46:06 UTC
Good to know it's harmless- When I was looking at the code I couldn't tell (I'm
not that familiar with how the USB interacts here).

If all was working, the printer would print. Instead it claims the printer
is not connected. yet, lsusb shows the printer connected. The status (lpc
status)on the queue indicates that queueing and printing is enabled, with
two entries (test pages), and the daemon is present.

In fedora 11 all I need to do was put the printer on-line (or power cycle)
and it will start. In Fedora 13, nothing happens.

Comment 7 Tim Waugh 2010-07-28 13:23:19 UTC
It's complicated by the fact that we have to run the udev hook twice: once for the raw device, and once for the usblp device.  One will always fail, hence the error message.

The "not connected" message you're seeing will be due to the 'connecting-to-device' printer state reason being set for more than 60 seconds continuously.  The reason for that is not clear.

I can see from the troubleshooting output that you're using the 'usb' backend, but there is no error_log output from a test page -- were you given the opportunity to print one as part of the troubleshooting process?  Could you have another try please?

Comment 8 Jesse Pollard 2010-07-28 14:41:44 UTC
I haven't been able to get any diagnostic errors out - each time I try
the "test page" the queue gets another entry with the status "Processing - Not connected?"

Sometimes (not every time) when I recycle the printer I get prompted to install
drivers: foomatic-4.0.4-9.fc13 (x86_64) and hpijs-1:3.10.2-11.fc13 (x86_64).
When I do that I get "Failed to install package - Unknown error...", and
under "more details" the message "could not do simulate: The packages are already
installed".

After that there is a"new" printer (OfficeJet-G55-2). If I then attempt to print
a test page (with the queue shown for the "-2" printer) the job shows in the
queue briefly, then vanishes. But nothing on the printer. The queue status
(at the bottom) shows "Printer 'OfficeJet-G55' may not be connected, which
I believe is the other instance... and it looks like the test page entry has
been redirected to the original queue.

No diagnostic options are presented (other than print test page). The
printer apparently does not support the "Print Self-Test Page" or "clean
Print Heads" options ('client-error-document-format-not-supported' is the
cups error message when I try these).

I HAVE seen the diagnostics prompt - but only before the typographic error
was fixed.

Comment 9 Tim Waugh 2010-07-28 15:06:01 UTC
What I'd like you to do is: delete all the queues relating to this printer.  Then, reconnect the printer -- a queue for it should be created. (The 'already installed' problem is reported elsewhere in bugzilla already...)

Then run the troubleshooter as in comment #1, and when you are given the opportunity to print a test page, do so.  Attach the troubleshoot.txt file here.  Thanks.

Comment 10 Jesse Pollard 2010-07-28 15:31:20 UTC
Created attachment 435048 [details]
trouble shooting output

Sorry about my oversight...

Here you are. I did try several times - this one is from a clean cycle
disconnect, connect, the install bug, then the troubleshoot options.

currently the printer is "Not connected"...

Comment 11 Jesse Pollard 2010-07-28 17:28:00 UTC
Created attachment 435088 [details]
additional trouble report

This is an additional troubleshoot log - This has a different error that what
I was getting.

I noticed that the printer had powered off a bit ago, so I powered it on and
ran through the troubleshoot menus.

The error this time was "missing attributes"...

Comment 12 Jesse Pollard 2010-08-15 17:06:37 UTC
Additional info -

The OfficeJet is also a scanner - when I tried to scan all I could get
"scanner offline".


For the time being, I have dropped back to Fedora 11, where printing
and scanning work.

Comment 13 Jiri Popelka 2010-08-17 13:42:36 UTC
I see the queue is set up with Foomatic/hpijs driver.
Can you try (if you still have Fedora-13 somewhere) to
change the driver to gutenprint or hpcups.

- run system-config-printer
- double-click on the queue
- press the lower 'Change...' button to change 'Make and Model'
- select printer from database, select HP, Forward
- select OfficeJet G55
- try another (than Foomatic/hpijs) driver, Forward
- 'Use the new PPD as is', Forward

Try to print and if you get different results, attach troubleshooter output.
thanks

Comment 14 Jesse Pollard 2010-08-17 23:56:46 UTC
Created attachment 439260 [details]
testing different printer model

Still no luck. printer is still "busy", and not printing.

Printer status is online

Note brief addition - I have power cycled the printer, and got:

[root@localhost ~]# system-config-printer
**
Gtk:ERROR:gtkfilesystemmodel.c:746:gtk_file_system_model_sort: assertion failed: (r == n_visible_rows)
Aborted (core dumped)
[root@localhost ~]# 

Sorry, no core dump was actually made.

This occured following the attachment

Comment 15 Jesse Pollard 2010-08-18 00:05:49 UTC
Created attachment 439261 [details]
Another try

This is with still another combination - different result.

The file is reported as printed, but nothing came out.

Comment 16 Jesse Pollard 2010-08-18 00:10:08 UTC
Tried again, but the same result as the first time - printer did not print.

Comment 17 Jesse Pollard 2010-08-18 00:14:09 UTC
Tried scanner again - no luck:

"Failed to open device `hpaio:/usb/OfficeJet_G55?serial=SGG13E04MKVL':
Device busy.

This sounds like a USB problem - could it be in libusb? I'm curious
because I am capable to dig into code - but there is just so much of it
to start with.

Comment 18 Jiri Popelka 2010-08-18 08:03:03 UTC
(In reply to comment #17)
> Tried scanner again - no luck:
> 
> "Failed to open device `hpaio:/usb/OfficeJet_G55?serial=SGG13E04MKVL':
> Device busy.

Do you have the libsane-hpaio package installed?

Comment 19 Jesse Pollard 2010-08-18 09:31:57 UTC
Yes - from the rpm report:

libsane-hpaio-3.10.5-1.fc13.x86_64

Comment 20 skeeter9807 2010-08-29 19:13:27 UTC
I have encountered a similar problem as Jesse Pollard is describing. 

Background:  I use Fedora as a livecd on a USB stick.  I spin my own version using the fedora-live-base.ks/fedora-livecd-desktop.ks kickstart files included in the spin-kickstarts rpm as a base for my own spin.  I add to the distibuted kickstart files a number of additional packages that I need.  I respin regularly as I see security-related updates become available.  

I have been spinning my own versions of Fedora since release 10 and automatic printer detection has always been included and functional until very recently.  That is, when I turned on my printer (HP LaserJet 1200), Fedora 10 recognized it and automatically installed the correct printer driver.  I was ready to print within a few seconds with no intervention on my part. 

Same thing for Fedora 11:  Automatic printer detection worked.

Same thing for Fedora 12:  Automatic printer detection worked....until some time between 25 June 2010 and 8 August 2010

The problem:  On 25 June 2010, I did a respin using my usual kickstart files. The resulting respin recognized and installed my hp 1200 when it was turned on.  On 8 August 2010, I did a respin using my usual kickstart files and the automatic printer recognition did NOT work.  

Unlike Jesse Pollard, I CAN manually install my printer and it works just fine.  But having to manually install the printer each time I want to use it, defeats the purpose of the livecd.

Following are the relevant portions of the logs for printer recognition for the 25 June respin and for the 8 August respin.   

**Pls note** line 7 and line 9 from the first log is missing from the second log:

-->fc12 25 June 10 dmesg shows the following after switching on the printer

     1. usb 3-2: new full speed USB device using uhci_hcd and address 2
     2. usb 3-2: New USB device found, idVendor=03f0, idProduct=0317
     3. usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
     4. usb 3-2: Product: HP LaserJet 1200
     5. usb 3-2: Manufacturer: HewLett Packard
     6. usb 3-2: SerialNumber: #############
>>==>7. usb 3-2: configuration #1 chosen from 1 choice
     8. usblp0: USB Bidirectional printer dev 2 if 0 alt 1 proto 2 vid 0x03F0 pid 0x0317
>>==>9. usbcore: registered new interface driver usblp

-->fc12 8 Aug 2010 dmesg shows the following after switching on the printer

     1. usb 3-2: new full speed USB device using uhci_hcd and address 3
     2. usb 3-2: New USB device found, idVendor=03f0, idProduct=0317
     3. usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
     4. usb 3-2: Product: HP LaserJet 1200
     5. usb 3-2: Manufacturer: HewLett Packard
     6. usb 3-2: SerialNumber: ###########
     7. usblp0: USB Bidirectional printer dev 3 if 0 alt 1 proto 2 vid 0x03F0 pid 0x0317

Whatever process produced the results of line 7 in the first log above was dropped from Fedora 12 between 25 June and 8 August.  

It would be MUCH appreciated if this process/auto printer support could be added back into the distributions!

Failing that, I would be almost as much pleased if you could provide a single command line solution to installing a HP LaserJet 1200 so as to avoid having to go through localhost:631 or system-config-printer.

NOTE:  I also have experimented with Fedora 13.  The livecd available for download on the various mirrors dated 12 May 2010 contains automatic printer support.  My respins dated August 2010 do not contain the automatic printer support.  

Thanks for your help.

--Skeeter

Comment 21 Tim Waugh 2010-08-31 09:09:54 UTC
Perhaps you could track down the kernel version you were using in the June 25th spin, and try that out on newer spins?

Comment 22 skeeter9807 2010-09-02 02:23:52 UTC
Tim,

The thought occurred to me as I was trying to sort out my printer problem that the kernel might be the culprit, but I did not think of doing a respin with the kernel used for the LiveCD release that was able to auto install my printer.  Thanks for the suggestion.

Last night, I did a respin of F13 with kernel-22.6.33.3-85.fc13.i686, which was the kernel in the release version of the LiveCD.  Unfortunately that did not solve the problem.  The release LiveCD auto installs the printer, but the respin using the same kernel does not.  The problem lies elsewhere.

Any additional thoughts?  Again auto install of printer worked in FC10, FC12 and FC13 through the end of June 2010.  But by August 2010, it did not work.  What changed during July that would affect this handy feature?

Cheers,
Skeeter

Comment 23 Tim Waugh 2010-09-02 08:46:28 UTC
Looking through the bodhi stable updates for F13 by release date (starting on page 16 now), the possible candidates just based on package name are:

selinux-policy
kernel
dbus-glib
glibc
gnome-packagekit
PackageKit

Going back through to a little into June:

system-config-printer-1.2.3-3.fc13 (June 28th)

Maybe system-config-printer is the one to start with.  Try using the one from before that update, system-config-printer-1.2.2-4.fc13.

Comment 24 Jesse Pollard 2010-09-02 13:41:14 UTC
That works as expected. Thanks.

Hopefully now the bug can be eliminated.

Comment 25 Jesse Pollard 2010-09-02 13:47:23 UTC
A brief follow up.

I had to remove system-config-printer (actually, I removed
system-config-printer-libs and dependancies) and then
installed system-config-printer-1.2.3-3.fc13.

yum wouldn't let me downgrade for some reason - though I tried to downgrade
both system-config-printer and system-config-printer-libs.

Scanning also works fine (xsane).

Comment 26 Tim Waugh 2010-09-02 14:29:54 UTC
Thanks.  Hopefully I'll get some time to look into it before too long, but it won't be for a couple of weeks.

One thing you can do to get more information about the problem is to catch the debugging information from system-config-printer-udev as it spots the new printer.  To do this, edit /etc/rsyslog.conf and change '*.info' to '*.debug' in the /var/log/messages line; then '/sbin/service rsyslog restart'.

Now you should get debugging messages in /var/log/messages when you plug in the printer.

Comment 27 Jesse Pollard 2010-09-02 14:36:05 UTC
do you want a log from the current release of system-config-printer?

The following is the syslog activity (including the downgraded system-config-printer:

Sep  2 09:37:45 localhost yum[27630]: Installed: system-config-printer-libs-1.2.3-3.fc13.x86_64
Sep  2 09:37:46 localhost yum[27630]: Installed: system-config-printer-1.2.3-3.fc13.x86_64
Sep  2 09:38:26 localhost kernel: parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,EPP]
Sep  2 09:38:26 localhost kernel: parport0: irq 7 detected
Sep  2 09:38:26 localhost kernel: lp0: using parport0 (polling).
Sep  2 09:38:26 localhost kernel: lp0: console ready
Sep  2 09:38:26 localhost kernel: ppdev: user-space parallel port driver
Sep  2 09:38:26 localhost hp[27680]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Sep  2 09:38:26 localhost python: io/hpmud/pp.c 627: unable to read device-id ret=-1
Sep  2 09:39:55 localhost kernel: usblp0: removed
Sep  2 10:32:31 localhost kernel: Kernel logging (proc) stopped.
Sep  2 10:32:31 localhost rsyslogd: [origin software="rsyslogd" swVersion="4.4.2" x-pid="1185" x-info="http://www.rsyslog.com"] exiting on signal 15.
Sep  2 10:32:31 localhost kernel: imklog 4.4.2, log source = /proc/kmsg started.
Sep  2 10:32:31 localhost rsyslogd: [origin software="rsyslogd" swVersion="4.4.2" x-pid="31667" x-info="http://www.rsyslog.com"] (re)start
Sep  2 10:32:54 localhost kernel: usb 7-1: USB disconnect, address 2
Sep  2 10:33:00 localhost kernel: usb 7-1: new full speed USB device using uhci_hcd and address 3
Sep  2 10:33:00 localhost kernel: usb 7-1: New USB device found, idVendor=03f0, idProduct=0011
Sep  2 10:33:00 localhost kernel: usb 7-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Sep  2 10:33:00 localhost kernel: usb 7-1: Product: OfficeJet G55
Sep  2 10:33:00 localhost kernel: usb 7-1: Manufacturer: Hewlett-Packa
Sep  2 10:33:00 localhost kernel: usb 7-1: SerialNumber: SGG13E04MKVL
Sep  2 10:33:00 localhost kernel: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 3 vid 0x03F0 pid 0x0011

Comment 28 Tim Waugh 2010-09-02 15:15:07 UTC
So this is a log from a failed run, i.e. the queue didn't get installed -- correct?

There aren't any of the messages I expect to see, like this:

Aug 17 15:58:35 worm udev-configure-printer: add /devices/pci0000:00/0000:00:1d.
7/usb1/1-6/1-6.3/1-6.3:1.1
Aug 17 15:58:35 worm udev-configure-printer: parent devpath is /devices/pci0000:
00/0000:00:1d.7/usb1/1-6/1-6.3
Aug 17 15:58:35 worm udev-configure-printer: Device vendor/product is 03F0:2911
Aug 17 15:58:35 worm udev-configure-printer: add /devices/pci0000:00/0000:00:1d.
7/usb1/1-6/1-6.3/1-6.3:1.1/usb/lp0
Aug 17 15:58:35 worm udev-configure-printer: failed to claim interface
Aug 17 15:58:35 worm udev-configure-printer: invalid or missing IEEE 1284 Device
 ID
Aug 17 15:58:35 worm udev-configure-printer: parent devpath is /devices/pci0000:
00/0000:00:1d.7/usb1/1-6/1-6.3
Aug 17 15:58:35 worm udev-configure-printer: MFG:Hewlett-Packard MDL:PSC 2200 Se
ries SERN:12345 serial:12345
Aug 17 15:58:51 worm udev-configure-printer: SERN fields match
Aug 17 15:58:51 worm udev-configure-printer: URI match: usb://HP/PSC%202200%20Se
ries?serial=12345
Aug 17 15:58:51 worm udev-configure-printer: SERN fields match
Aug 17 15:58:51 worm udev-configure-printer: URI match: hp:/usb/PSC_2200_Series?
serial=12345
Aug 17 15:58:51 worm udev-configure-printer: hp:/usb/PSC_2200_Series?serial=12345 twinned with hpfax:/usb/PSC_2200_Series?serial=12345
Aug 17 15:58:51 worm udev-configure-printer: About to add queue for hp:/usb/PSC_
2200_Series?serial=12345
Aug 17 15:58:51 worm udev-add-printer: add_queue: URIs=['hp:/usb/PSC_2200_Series?serial=12345', 'usb://HP/PSC%202200%20Series?serial=12345', 'hpfax:/usb/PSC_2200_Series?serial=12345']

Comment 29 Jesse Pollard 2010-09-02 16:12:11 UTC
This was just unplugging the printer, waiting a while, and then plugging it
back in.

The queue already existed as created by the 1.2.3-3 version.

Should there be a reboot? I did restart rsyslog.
And would you like one with the current version too (though I may have to wait
a bit - my wife wants the system this afternoon).

Comment 30 Tim Waugh 2010-09-03 08:28:12 UTC
What does 'grep debug /etc/rsyslog.conf' say?  It should be something like this:

*.debug;mail.none;authpriv.none;cron.none                -/var/log/messages

Comment 31 Jesse Pollard 2010-09-03 11:36:26 UTC
The only difference I see is your "-". The only change I made to mine
was to replace the "*.info" with "*.debug"
*.debug;mail.none;authpriv.none;cron.none                /var/log/messages

Comment 32 skeeter9807 2010-09-03 15:29:22 UTC
Tim,

re comment 23:  removing system-config-printer, system-config-printer-libs, and system-config-printer-udev and replacing these files with the same packages from fc13 release fixes the automatic printer installation bug.  

When you have the time, please try to find what is missing from the current release, and add it back in.  Thanks for your help.

--Skeeter

Comment 33 Oliver Dreier 2010-09-04 22:51:37 UTC
Hello,
i run in the same problem with this printer: Seiko Epson Corp. Stylus CX3700/CX3800/DX3800.

After reading this issue, i do this:
yum downgrade system-config-printer.i686 system-config-printer-libs system-config-printer-udev
and everything works normal.

-- Oliver

Comment 34 skeeter9807 2010-09-18 01:01:07 UTC
Tim,

Your updates to system-config-printer et al fix the problem.  Kudos and many thanks.

Cheers,
Skeeter

Comment 35 Tim Waugh 2010-09-22 10:09:57 UTC
(In reply to comment #34)
> Your updates to system-config-printer et al fix the problem.  Kudos and many
> thanks.

Er.. I still don't know what the problem is here, and I haven't changed any code in this area recently.  I expect the problem still remains...

Comment 36 skeeter9807 2010-09-27 13:20:35 UTC
Well, it remains a mystery then.  That being said system-config-printer-1.2.4-1.fc13.i686 et al (the packages currently in updates) with whatever dependencies those packages currently are pulling in result in my printer being automatically detected, which is what I wanted.  So for me, at least, the bug is fixed.

Comment 37 Jesse Pollard 2010-09-27 13:40:46 UTC
I note that there have been some udev updates since seeing the problem.

I too have tried using the current kit - and it does seem to be working
for me too. I have rebooted the system a couple of times (new kernel)
since restoring updates to system-config-printer and the printer is
still working - along with scanning.

I now suspect that the bug was actually external to system-config-printer, but
was only tickled by the current system-config-printer, but not by the older
one.

so for the time being, you can count this as a "it works for me too", though
the problem may still reoccur in the future.

Comment 38 Tim Waugh 2010-09-27 14:08:17 UTC
OK, most likely it was udev after all then.  Thanks for the update.


Note You need to log in before you can comment on or make changes to this bug.