Bug 61664 - Do ISO's downloadable via RHN contain current package RPM's?
Do ISO's downloadable via RHN contain current package RPM's?
Status: CLOSED DEFERRED
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg DeKoenigsberg
Jay Turner
http://webapp.rwc-colo.redhat.com/net...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-22 14:07 EST by Tommy Reynolds
Modified: 2015-01-07 18:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-22 16:53:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tommy Reynolds 2002-03-22 14:07:03 EST
How Reproducible:


Steps to Reproduce:
1. Go to http://webapp.rwc-colo.redhat.com/network/channel/download_isos.pxt and
login as tommyreynolds
2.
3.

Actual Results:


Expected Results:


Additional Information:

When attempting to download an ISO, it is not clear from the working whether
this is going to be a pristine as-released ISO, or whether it is a "virtual" ISO
containing the current snapshot including the errata RPM's.  I'd prefer a
"virtual" ISO that would be today's versions of all my configured packages.
Comment 1 Jay Turner 2002-03-22 14:22:14 EST
Would be lovely, but I don't see this happening anytime soon.  Making this
happen would mean that we were rebuilding anaconda with every ISO, and we just
don't have that kind of time to push the results through QA.
Comment 2 Tommy Reynolds 2002-03-22 14:26:52 EST
But isn't this effectively what we have with RHN and "up2date"?  Just because
it's delivered in a single file instead of tons'o downloaded RPM changes our
support policy?
Comment 3 Jay Turner 2002-03-22 14:59:40 EST
You are simplifying the process way too much.  RHN and up2date allow the user to
download updated packages for their already installed system.  Putting together
installable ISOs on the fly which include the latest and greatest is quite a bit
different.  First and foremost, the installer itself (anaconda) has to feed an
updated package listing (with the new versions) and the header list has to be
regenerated.  Then the resulting ISO image would have to undergo testing to
verify that it works as it should.  We might be able to start thinking about
doing stuff like this with the next major version switch, but definitely not at
this point.
Comment 4 Tommy Reynolds 2002-03-22 16:52:33 EST
I believe you; never claimed to know anything about the gory details ;-)

I'll happliy accept a "we'll consider this for a future enhancement" note.

If we can wordsmith the RHN web page about ISO's to clarify that it is the
pristine original ISO's that are downloaded, I'll be satisfied for the nonce.
Comment 5 Chip Turner 2002-04-03 16:16:18 EST
This is more of a longterm goal on our roadmap than a bugzilla at this point.

Note You need to log in before you can comment on or make changes to this bug.