Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 616640 - xcb_io.c:183: process_responses: Assertion `!(req && current_request && !(((long) (req->sequence) - (long) (current_request)) <= 0))' failed
xcb_io.c:183: process_responses: Assertion `!(req && current_request && !(((l...
Status: CLOSED DUPLICATE of bug 543165
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
13
i686 Linux
low Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 23:24 EDT by Alex Mondshain
Modified: 2018-04-11 02:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-07 07:05:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Mondshain 2010-07-20 23:24:10 EDT
Description of problem:

Skype continuously core dumps with above message, the bug is referenced and shown as fixed in both ubuntu and suse bugzilla's  

https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/559595
https://bugzilla.novell.com/show_bug.cgi?id=302173

There are other references, google shows a load of them .. 

Version-Release number of selected component (if applicable):
Fedora 13 with last updates 

Alex M
Comment 1 Alex Mondshain 2010-08-20 14:26:49 EDT
Debug trace

[New Thread 32411]
[New Thread 32412]
[New Thread 32416]
[New Thread 32409]
[New Thread 32418]
[New Thread 32413]
[New Thread 32420]
[New Thread 32410]
Core was generated by `/usr/bin/skype'.
Program terminated with signal 6, Aborted.
#0  0x00bc1424 in __kernel_vsyscall ()

Thread 8 (Thread 32410):
#0  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00a705d4 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S:236
No locals.
#2  0x083aa0bc in ?? ()
No symbol table info available.
#3  0x083c3c78 in ?? ()
No symbol table info available.
#4  0x083aa989 in ?? ()
No symbol table info available.
#5  0x00a6c919 in start_thread (arg=0x1208b70) at pthread_create.c:301
        __res = <value optimized out>
        __ignore1 = 128
        __ignore2 = 249
        pd = 0x1208b70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {11001844, 0, 4001536, 
    18908120, -393340103, -468055750}, mask_was_saved = 0}}, priv = {pad = {
    0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#6  0x00982cbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133
No locals.

Thread 7 (Thread 32420):
#0  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00a7022c in pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
No locals.
#2  0x083aa101 in ?? ()
No symbol table info available.
#3  0x086c2f76 in ?? ()
No symbol table info available.
#4  0x083aa989 in ?? ()
No symbol table info available.
#5  0x00a6c919 in start_thread (arg=0x72b8b70) at pthread_create.c:301
        __res = <value optimized out>
        __ignore1 = 128
        __ignore2 = 1
        pd = 0x72b8b70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {11001844, 0, 4001536, 
    120292312, -24241355, -468055750}, mask_was_saved = 0}}, priv = {pad = {
    0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#6  0x00982cbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133
No locals.

Thread 6 (Thread 32413):
#0  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00977de6 in __poll (fds=0xa783c58, nfds=5, timeout=100000)
    at ../sysdeps/unix/sysv/linux/poll.c:87
        resultvar = <value optimized out>
        resultvar = <value optimized out>
        oldtype = -516
        result = <value optimized out>
#2  0x083a1643 in ?? ()
No symbol table info available.
#3  0x083aeb85 in ?? ()
No symbol table info available.
#4  0x0839866c in ?? ()
No symbol table info available.
#5  0x083aa989 in ?? ()
No symbol table info available.
#6  0x00a6c919 in start_thread (arg=0x9435b70) at pthread_create.c:301
        __res = <value optimized out>
        __ignore1 = 5
        __ignore2 = 100000
        pd = 0x9435b70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {11001844, 0, 4001536, 
    155407320, 791550761, -468055750}, mask_was_saved = 0}}, priv = {pad = {
    0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#7  0x00982cbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133
No locals.

Thread 5 (Thread 32418):
#0  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00a7022c in pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
No locals.
#2  0x083aa101 in ?? ()
No symbol table info available.
#3  0x086cac04 in ?? ()
No symbol table info available.
#4  0x083aa989 in ?? ()
No symbol table info available.
#5  0x00a6c919 in start_thread (arg=0xa573b70) at pthread_create.c:301
        __res = <value optimized out>
        __ignore1 = 128
        __ignore2 = 3
        pd = 0xa573b70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {11001844, 0, 4001536, 
    173487064, 133045039, -468055750}, mask_was_saved = 0}}, priv = {pad = {
    0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#6  0x00982cbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133
No locals.

Thread 4 (Thread 32409):
#0  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00977de6 in __poll (fds=0xa8bdb70, nfds=4, timeout=45)
    at ../sysdeps/unix/sysv/linux/poll.c:87
        resultvar = <value optimized out>
        resultvar = <value optimized out>
        oldtype = -516
        result = <value optimized out>
#2  0x0054264c in IA__g_poll (fds=0xa8bdb70, nfds=4, timeout=45)
    at gpoll.c:127
No locals.
#3  0x00535044 in g_main_context_poll (context=0xa6f490, block=1, dispatch=1, 
    self=0xa7024a8) at gmain.c:2904
        poll_func = 0x542620 <IA__g_poll>
#4  g_main_context_iterate (context=0xa6f490, block=1, dispatch=1, self=
    0xa7024a8) at gmain.c:2586
        max_priority = 2147483647
        timeout = 45
        some_ready = <value optimized out>
        nfds = 4
        allocated_nfds = <value optimized out>
        fds = 0xa8bdb70
        __PRETTY_FUNCTION__ = "g_main_context_iterate"
#5  0x00535449 in IA__g_main_context_iteration (context=0xa706690, may_block=
    1) at gmain.c:2654
        retval = <value optimized out>
#6  0x05c34446 in QEventDispatcherGlib::processEvents (this=0xa7023a8, flags=
    ...) at kernel/qeventdispatcher_glib.cpp:412
        d = 0xa7023b8
        canWait = <value optimized out>
        result = <value optimized out>
#7  0x06422336 in QGuiEventDispatcherGlib::processEvents (this=0xa7023a8, 
    flags=...) at kernel/qguieventdispatcher_glib.cpp:204
        d = 0xa7023b8
        returnValue = 252
#8  0x05c0a80a in QEventLoop::processEvents (this=0xbfb75984, flags=...)
    at kernel/qeventloop.cpp:149
        d = 0xa743690
#9  0x05c0ab4a in QEventLoop::exec (this=0xbfb75984, flags=...)
    at kernel/qeventloop.cpp:201
        d = 0xa743690
#10 0x05c0e807 in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:1003
        threadData = 0xa6fd6f0
        eventLoop = {<QObject> = {_vptr.QObject = 0x5d218e8, 
            static staticMetaObject = {d = {superdata = 0x0, stringdata = 
    0x5cafee0 "QObject", data = 0x5caff80, extradata = 0x5d1c700}}, d_ptr = {
              d = 0xa743690}, static staticQtMetaObject = {d = {superdata = 
    0x0, stringdata = 0x5cb8a20 "Qt", data = 0x5cbc080, extradata = 0x0}}}, 
          static staticMetaObject = {d = {superdata = 0x9209e38, stringdata = 
    0x5cc1ae0 "QEventLoop", data = 0x5cc1b00, extradata = 0x0}}}
        returnCode = <value optimized out>
#11 0x06373828 in QApplication::exec () at kernel/qapplication.cpp:3585
No locals.
#12 0x08070d0e in ?? ()
No symbol table info available.
#13 0x008bbcc6 in __libc_start_main (main=0x806f4b0, argc=1, ubp_av=
    0xbfb75cb4, init=0x8bb3fc0, fini=0x8bb3fb0, rtld_fini=
    0x88e220 <_dl_fini>, stack_end=0xbfb75cac) at libc-start.c:226
        result = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {10670068, 0, 0, 
    -1078502264, -952894908, -1091384006}, mask_was_saved = 0}}, priv = {
            pad = {0x0, 0x0, 0x1, 0x806f230}, data = {prev = 0x0, cleanup = 
    0x0, canceltype = 1}}}
        not_first_call = <value optimized out>
#14 0x0806f251 in ?? ()
No symbol table info available.

Thread 3 (Thread 32416):
#0  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00a7022c in pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
No locals.
#2  0x083aa101 in ?? ()
No symbol table info available.
#3  0x084588a3 in ?? ()
No symbol table info available.
#4  0x083aa989 in ?? ()
No symbol table info available.
#5  0x00a6c919 in start_thread (arg=0x26ceb70) at pthread_create.c:301
        __res = <value optimized out>
        __ignore1 = 128
        __ignore2 = 11
        pd = 0x26ceb70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {11001844, 0, 4001536, 
    40690648, 1884166975, -468055750}, mask_was_saved = 0}}, priv = {pad = {
    0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#6  0x00982cbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133
No locals.

Thread 2 (Thread 32412):
#0  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00a7022c in pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
No locals.
#2  0x083aa101 in ?? ()
No symbol table info available.
#3  0x08770d3b in ?? ()
No symbol table info available.
#4  0x083aa989 in ?? ()
No symbol table info available.
#5  0x00a6c919 in start_thread (arg=0x2969b70) at pthread_create.c:301
        __res = <value optimized out>
        __ignore1 = 128
        __ignore2 = 1
        pd = 0x2969b70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {11001844, 0, 4001536, 
    43422680, -2068964546, -468055750}, mask_was_saved = 0}}, priv = {pad = {
    0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#6  0x00982cbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133
No locals.

Thread 1 (Thread 32411):
#0  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#1  0x008cfd11 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = <value optimized out>
        resultvar = <value optimized out>
        pid = 10670068
        selftid = 32411
#2  0x008d15ea in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x9fd87f4, sa_sigaction = 
    0x9fd87f4}, sa_mask = {__val = {134522148, 167610344, 9038420, 0, 
    1828096, 5, 0, 1, 9038072, 0, 167610660, 8993920, 10668800, 167613120, 6, 
    615, 167616512, 0, 167610416, 167610292, 167610344, 167610356, 167610296, 
    167613116, 9038072, 0, 149617370, 134616497, 0, 0, 0, 0}}, sa_flags = 0, 
          sa_restorer = 0}
        sigs = {__val = {32, 0 <repeats 31 times>}}
#3  0x088479d0 in ?? ()
No symbol table info available.
#4  <signal handler called>
No symbol table info available.
#5  0x00bc1424 in __kernel_vsyscall ()
No symbol table info available.
#6  0x008cfd11 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = <value optimized out>
        resultvar = <value optimized out>
        pid = 10670068
        selftid = 32411
#7  0x008d15ea in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0xb7600010, sa_sigaction = 
    0xb7600010}, sa_mask = {__val = {10670068, 160, 1, 167611904, 167611692, 
    0, 304, 150, 3076522000, 10670068, 150, 149, 167611864, 9488610, 
    3073136832, 150, 167611904, 3072870632, 0, 4222451712, 3073136832, 
    3073136933, 3073136832, 3073136832, 3073136981, 3073137132, 3073136832, 
    3073137132, 0, 0, 0, 0}}, sa_flags = 0, sa_restorer = 0xb}
        sigs = {__val = {32, 0 <repeats 31 times>}}
#8  0x008c8d98 in __assert_fail (assertion=
    0x3abfec "!(req && current_request && !(((long) (req->sequence) - (long) (current_request)) <= 0))", file=0x3abf29 "xcb_io.c", line=183, function=
    0x3ac0ca "process_responses") at assert.c:81
        buf = 
    0xb72c58c0 "skype: xcb_io.c:183: process_responses: Assertion `!(req && current_request && !(((long) (req->sequence) - (long) (current_request)) <= 0))' failed.\n"
#9  0x0033ba8c in process_responses (dpy=<value optimized out>, 
    wait_for_first_event=0, current_error=0x9fd8edc, current_request=340)
    at xcb_io.c:183
        req = 0xa9a1120
        event_sequence = <value optimized out>
        reply = 0x1755b71d
        event = 0x0
        error = 0x0
        c = 0xb72baf60
        __PRETTY_FUNCTION__ = "process_responses"
#10 0x0033c016 in _XReply (dpy=0xb72ba618, rep=0x9fd8f20, extra=0, discard=1)
    at xcb_io.c:464
        error = <value optimized out>
        c = 0xafdaf78
        reply = 0xafdaf78 "\001\003T\001"
        current = 0xb7159460
        __PRETTY_FUNCTION__ = "_XReply"
#11 0x0538e4fe in XScreenSaverQueryInfo (dpy=0xb72ba618, drawable=347, 
    saver_info=0xb760cae8) at XScrnSaver.c:224
        info = <value optimized out>
        rep = {type = 164 '\244', state = 93 ']', sequenceNumber = 49079, 
          length = 3216469395, window = 167612248, tilOrSince = 9251170, 
          idle = 3216469397, eventMask = 150316965, kind = 1 '\001', pad0 = 
    0 '\000', pad1 = 0, pad2 = 150316965}
#12 0x08848063 in ?? ()
No symbol table info available.
#13 0x084e96c5 in ?? ()
No symbol table info available.
#14 0x08334bd9 in ?? ()
No symbol table info available.
#15 0x083aa989 in ?? ()
No symbol table info available.
#16 0x00a6c919 in start_thread (arg=0x9fd9b70) at pthread_create.c:301
        __res = <value optimized out>
        __ignore1 = 32411
        __ignore2 = 6
        pd = 0x9fd9b70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {11001844, 0, 4001536, 
    167613400, 1387141928, -468055750}, mask_was_saved = 0}}, priv = {pad = {
    0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#17 0x00982cbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133
No locals.
From        To          Syms Read   Shared Object Library
0x07ea4e00  0x07f371d8  Yes         /lib/libasound.so.2
0x05241c00  0x05244228  Yes         /usr/lib/libXv.so.1
0x0538d8f0  0x0538e768  Yes         /usr/lib/libXss.so.1
0x00a99880  0x00a9d6b8  Yes         /lib/librt.so.1
0x007e6120  0x00832848  Yes         /usr/lib/libQtDBus.so.4
0x063654f0  0x06a49f78  Yes         /usr/lib/libQtGui.so.4
0x05d46320  0x05de7d68  Yes         /usr/lib/libQtNetwork.so.4
0x05aff790  0x05c69f68  Yes         /usr/lib/libQtCore.so.4
0x00a6a5e0  0x00a76558  Yes         /lib/libpthread.so.0
0x00251610  0x002c4098  Yes         /usr/lib/libstdc++.so.6
0x00a36470  0x00a50968  Yes         /lib/libm.so.6
0x00dcbfa0  0x00de4438  Yes         /lib/libgcc_s.so.1
0x008bbaa0  0x009db1f4  Yes         /lib/libc.so.6
0x00a5fa60  0x00a60a88  Yes         /lib/libdl.so.2
0x0030d370  0x0039e908  Yes         /usr/lib/libX11.so.6
0x00d266e0  0x00d30ef8  Yes         /usr/lib/libXext.so.6
0x0087f830  0x008973bf  Yes         /lib/ld-linux.so.2
0x007a15f0  0x007c51c8  Yes         /usr/lib/libQtXml.so.4
0x00116220  0x00142578  Yes         /lib/libdbus-1.so.3
0x00d52f40  0x00d546b8  Yes         /lib/libgthread-2.0.so.0
0x00509590  0x00595478  Yes         /lib/libglib-2.0.so.0
0x0015b6f0  0x001776d8  Yes         /usr/lib/libpng12.so.0
0x00a84620  0x00a8f8e8  Yes         /lib/libz.so.1
0x004383c0  0x004a17f8  Yes         /usr/lib/freetype-freeworld/libfreetype.so.6
0x00d5f7d0  0x00d8b6f8  Yes         /lib/libgobject-2.0.so.0
0x00df2380  0x00df6d28  Yes         /usr/lib/libSM.so.6
0x00183530  0x001931f8  Yes         /usr/lib/libICE.so.6
0x0069c780  0x006a6608  Yes         /usr/lib/libXi.so.6
0x0019b2c0  0x001a1178  Yes         /usr/lib/libXrender.so.1
0x001a4150  0x001a8c38  Yes         /usr/lib/libXrandr.so.2
0x001abe70  0x001ae3a8  Yes         /usr/lib/libXfixes.so.3
0x001b1e40  0x001b7448  Yes         /usr/lib/libXcursor.so.1
0x00dfb780  0x00dfc258  Yes         /usr/lib/libXinerama.so.1
0x001c8f60  0x001e4cc8  Yes         /usr/lib/libfontconfig.so.1
0x0070fe60  0x00747ca8  Yes         /usr/lib/libssl.so.10
0x00e35e80  0x00f19768  Yes         /lib/libcrypto.so.10
0x004cfe80  0x004de608  Yes         /usr/lib/libxcb.so.1
0x00deaf00  0x00decb48  Yes         /lib/libuuid.so.1
0x00da2040  0x00dbaef8  Yes         /lib/libexpat.so.1
0x005fc750  0x0061e418  Yes         /lib/libgssapi_krb5.so.2
0x00c4ee50  0x00cb1e98  Yes         /lib/libkrb5.so.3
0x001bbd10  0x001bc938  Yes         /lib/libcom_err.so.2
0x006d97f0  0x006f4208  Yes         /lib/libk5crypto.so.3
0x00628650  0x00636f68  Yes         /lib/libresolv.so.2
0x00ba5a00  0x00ba67f8  Yes         /usr/lib/libXau.so.6
0x006ccc60  0x006d1238  Yes         /lib/libkrb5support.so.0
0x006c6860  0x006c6fc8  Yes         /lib/libkeyutils.so.1
0x00643190  0x006543b8  Yes         /lib/libselinux.so.1
0x001c1430  0x001c28e8  Yes         /usr/lib/gconv/UTF-16.so
0x006adc40  0x006b0b68  Yes         /usr/lib/kde4/plugins/gui_platform/libkde.so
0x06d0dbb0  0x06ea9208  Yes         /usr/lib/libkio.so.5
0x054891f0  0x056c5188  Yes         /usr/lib/libkdeui.so.5
0x00b31a40  0x00b65e38  Yes         /usr/lib/libQtSvg.so.4
0x0602fea0  0x061b9de8  Yes         /usr/lib/libkdecore.so.5
0x058be6c0  0x05907658  Yes         /usr/lib/libstreamanalyzer.so.0
0x00bcee40  0x00bef1b8  Yes         /usr/lib/libstreams.so.0
0x052ae5b0  0x052f9f38  Yes         /usr/lib/libsolid.so.4
0x05f69ec0  0x05f77de8  Yes         /usr/lib/libXft.so.2
0x05f801b0  0x05f8c2e8  Yes         /usr/lib/libXpm.so.4
0x006b4070  0x006b7f28  Yes         /usr/lib/libfam.so.0
0x006bc580  0x006c0af8  Yes         /lib/libacl.so.1
0x05fb7e30  0x05fba458  Yes         /lib/libattr.so.1
0x05396ec0  0x05399bd8  Yes         /usr/lib/libXtst.so.6
0x0075cfd0  0x0076a888  Yes         /lib/libbz2.so.1
0x05f92a90  0x05fa9f28  Yes         /usr/lib/liblzma.so.0
0x03eb5c10  0x03f9bf18  Yes         /usr/lib/libxml2.so.2
0x0077aa00  0x007829a8  Yes         /lib/libnss_files.so.2
0x0a47ca10  0x0a4d6848  Yes         /usr/lib/kde4/plugins/styles/oxygen.so
0x0076e920  0x007718e8  Yes         /usr/lib/qt4/plugins/imageformats/libqgif.so
0x0078fc10  0x00792ca8  Yes         /usr/lib/qt4/plugins/imageformats/libqico.so
0x0084c110  0x00850748  Yes         /usr/lib/qt4/plugins/imageformats/libqjpeg.so
0x073fb2d0  0x074156b8  Yes         /usr/lib/libjpeg.so.62
0x00854df0  0x00856678  Yes         /usr/lib/qt4/plugins/imageformats/libqmng.so
0x07565130  0x075b27a8  Yes         /usr/lib/libmng.so.1
0x077b0510  0x077d6b18  Yes         /usr/lib/liblcms.so.1
0x00775550  0x00776368  Yes         /usr/lib/qt4/plugins/imageformats/libqsvg.so
0x0085ae00  0x0085e0a8  Yes         /usr/lib/qt4/plugins/imageformats/libqtiff.so
0x07ac9d40  0x07afcf18  Yes         /usr/lib/libtiff.so.3
0x00861a60  0x00865378  Yes         /usr/lib/kde4/plugins/imageformats/kimg_dds.so
0x008693a0  0x0086c698  Yes         /usr/lib/kde4/plugins/imageformats/kimg_eps.so
0x00870ff0  0x00872618  Yes         /usr/lib/kde4/plugins/imageformats/kimg_exr.so
0x00875650  0x008771b8  Yes         /usr/lib/libImath.so.6
0x02b28910  0x02b776d8  Yes         /usr/lib/libIlmImf.so.6
0x00aacd20  0x00ab3258  Yes         /usr/lib/libIex.so.6
0x01209780  0x01209d08  Yes         /usr/lib/libHalf.so.6
0x00abb1b0  0x00abd178  Yes         /usr/lib/libIlmThread.so.6
0x0087aaa0  0x0087bfd8  Yes         /usr/lib/kde4/plugins/imageformats/kimg_jp2.so
0x07876f80  0x078ad598  Yes         /usr/lib/libjasper.so.1
0x00ac1ee0  0x00ac5c38  Yes         /usr/lib/kde4/plugins/imageformats/kimg_pcx.so
0x008a0a10  0x008a1fc8  Yes         /usr/lib/kde4/plugins/imageformats/kimg_psd.so
0x00aca3d0  0x00acf048  Yes         /usr/lib/kde4/plugins/imageformats/kimg_rgb.so
0x00ad7c10  0x00ad96a8  Yes         /usr/lib/kde4/plugins/imageformats/kimg_tga.so
0x00ae9200  0x00af3898  Yes         /usr/lib/kde4/plugins/imageformats/kimg_xcf.so
0x00add860  0x00adea08  Yes         /usr/lib/kde4/plugins/imageformats/kimg_xview.so
0x00ad2810  0x00ad3658  Yes         /lib/libnss_mdns4_minimal.so.2
0x00afbc00  0x00aff108  Yes         /lib/libnss_dns.so.2
$1 = 
    0xb72c58c0 "skype: xcb_io.c:183: process_responses: Assertion `!(req && current_request && !(((long) (req->sequence) - (long) (current_request)) <= 0))' failed.\n"
$2 = 0x0
eax            0x0	0
ecx            0x7e9b	32411
edx            0x6	6
ebx            0x7e99	32409
esp            0x9fd8718	0x9fd8718
ebp            0x9fd8730	0x9fd8730
esi            0x9f082f	10422319
edi            0xa2cff4	10670068
eip            0xbc1424	0xbc1424 <__kernel_vsyscall+16>
eflags         0x200206	[ PF IF ID ]
cs             0x73	115
ss             0x7b	123
ds             0x7b	123
es             0x7b	123
fs             0x0	0
gs             0x33	51
Dump of assembler code for function __kernel_vsyscall:
   0x00bc1414 <+0>:	push   %ecx
   0x00bc1415 <+1>:	push   %edx
   0x00bc1416 <+2>:	push   %ebp
   0x00bc1417 <+3>:	mov    %esp,%ebp
   0x00bc1419 <+5>:	sysenter 
   0x00bc141b <+7>:	nop
   0x00bc141c <+8>:	nop
   0x00bc141d <+9>:	nop
   0x00bc141e <+10>:	nop
   0x00bc141f <+11>:	nop
   0x00bc1420 <+12>:	nop
   0x00bc1421 <+13>:	nop
   0x00bc1422 <+14>:	jmp    0xbc1417 <__kernel_vsyscall+3>
=> 0x00bc1424 <+16>:	pop    %ebp
   0x00bc1425 <+17>:	pop    %edx
   0x00bc1426 <+18>:	pop    %ecx
   0x00bc1427 <+19>:	ret    
End of assembler dump.
Debuginfo absent: e859c85b9a1d3a61def6d4326cd8e0d6daaecbfe
Comment 2 Zdenek Kabelac 2010-08-24 14:13:08 EDT
I assume it's the same or related bug which causes my Thunderbird and Firefox instead of properly doing exit at the end of application it keeps looping here:

	if(req != current && req->reply_waiter)
		ConditionWait(dpy, dpy->xcb->reply_notify);

#0  _XReply (dpy=0x7f41b0a5b000, rep=0x7fff3dadb190, extra=0, discard=0) at xcb_io.c:524
#1  0x00007f41b4cb107f in XListExtensions (dpy=0x7f41b0a5b000, nextensions=0x7fff3dadb21c) at ListExt.c:48
#2  0x00007f41b86e1d82 in X11Error (display=0x7f41b0a5b000, event=0x7fff3dadbb30)
    at /usr/src/debug/thunderbird-3.1/comm-1.9.2/mozilla/toolkit/xre/nsX11ErrorHandler.cpp:85
#3  0x00007f41b4cc5797 in _XError (dpy=0x7f41b0a5b000, rep=0x7f4187e5e040) at XlibInt.c:3105
#4  0x00007f41b4ccc1b7 in handle_error (dpy=0x7f41b0a5b000, err=0x7f4187e5e040, in_XReply=<value optimized out>) at xcb_io.c:166
#5  0x00007f41b4ccc205 in handle_response (dpy=0x7f41b0a5b000, response=0x7f4187e5e040, in_XReply=<value optimized out>) at xcb_io.c:265
#6  0x00007f41b4cccbd0 in _XReply (dpy=0x7f41b0a5b000, rep=0x7fff3dadbcf0, extra=0, discard=1) at xcb_io.c:554
#7  0x00007f41b4cc0453 in XSync (dpy=0x7f41b0a5b000, discard=1) at Sync.c:46
#8  0x00007f41b4c9ecd0 in XCloseDisplay (dpy=0x7f41b0a5b000) at ClDisplay.c:65
#9  0x00007f41b649ae48 in gdk_display_x11_finalize (object=0x7f41b0a6c190) at gdkdisplay-x11.c:890
#10 0x00007f41b58df8c4 in g_object_unref (_object=0x7f41b0a6c190) at gobject.c:2580
#11 0x00007f41b86d7c17 in MOZ_gdk_display_close (display=0x7f41b0a6c190)
    at /usr/src/debug/thunderbird-3.1/comm-1.9.2/mozilla/toolkit/xre/nsAppRunner.cpp:2605
#12 0x00007f41b86dc5f2 in XRE_main (argc=<value optimized out>, argv=<value optimized out>, aAppData=<value optimized out>)
    at /usr/src/debug/thunderbird-3.1/comm-1.9.2/mozilla/toolkit/xre/nsAppRunner.cpp:3591
#13 0x0000000000401a94 in main (argc=1, argv=0x7fff3dadc5c8) at /usr/src/debug/thunderbird-3.1/comm-1.9.2/mail/app/nsMailApp.cpp:101
Comment 3 Andre Klapper 2010-09-16 04:33:24 EDT
I have just faced this while using rhythmbox in gdb and filed https://bugzilla.gnome.org/show_bug.cgi?id=629828 , however it's probably not a rhythmbox issue.
Comment 4 Zdenek Kabelac 2011-02-26 05:25:07 EST
Is there any progress on this bug ?

I'm seeing quite often endless loops with exit of Thunderbird and Firefox:
libX11-1.4.1-2.fc15.x86_64
firefox-4.0-0.16.b11.fc16.x86_64
thunderbird-3.1.7-6.fc15.x86_64


#0  0x00007fdddc113a05 in _XReply (dpy=0x7fddd6c57000, rep=0x7fff2ec0db00, extra=0, discard=0) at xcb_io.c:525
#1  0x00007fdddc0ffdd8 in XListExtensions (dpy=0x7fddd6c57000, nextensions=0x7fff2ec0db58) at ListExt.c:47
#2  0x00007fdde00429e3 in X11Error (display=0x7fddd6c57000, event=0x7fff2ec0e470) at nsX11ErrorHandler.cpp:83
#3  0x00007fdddc115e47 in _XError (dpy=0x7fddd6c57000, rep=0x7fdd62db5040) at XlibInt.c:1575
#4  0x00007fdddc112d21 in handle_error (dpy=0x7fddd6c57000, err=0x7fdd62db5040, in_XReply=<optimized out>) at xcb_io.c:166
#5  0x00007fdddc112d65 in handle_response (dpy=0x7fddd6c57000, response=0x7fdd62db5040, in_XReply=<optimized out>)
    at xcb_io.c:266
#6  0x00007fdddc113b60 in _XReply (dpy=0x7fddd6c57000, rep=0x7fff2ec0e620, extra=0, discard=1) at xcb_io.c:555
#7  0x00007fdddc10f333 in XSync (dpy=0x7fddd6c57000, discard=1) at Sync.c:44
#8  0x00007fdddc0edde0 in XCloseDisplay (dpy=0x7fddd6c57000) at ClDisplay.c:61
#9  0x00007fddddd24c98 in gdk_display_x11_finalize (object=0x7fddd6c65190 [GdkDisplayX11]) at gdkdisplay-x11.c:890
#10 0x00007fdddcd46651 in g_object_unref (_object=0x7fddd6c65190) at gobject.c:2734
#11 0x00007fdde0026678 in MOZ_gdk_display_close (display=0x7fddd6c65190 [GdkDisplayX11]) at nsAppRunner.cpp:2700
#12 0x00007fdde003da43 in XRE_main (argc=<optimized out>, argv=<optimized out>, aAppData=<optimized out>) at nsAppRunner.cpp:3858
#13 0x0000000000402f16 in main (argc=3, argv=0x7fff2ec100f0) at nsXULRunnerApp.cpp:463
Comment 5 Matěj Cepl 2011-03-07 07:05:15 EST

*** This bug has been marked as a duplicate of bug 543165 ***

Note You need to log in before you can comment on or make changes to this bug.