Bug 6167 - Permission problems for remote printing
Permission problems for remote printing
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-20 20:11 EDT by chris
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-29 17:17:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description chris 1999-10-20 20:11:19 EDT
Today I upgraded my lpr package to lpr-0.44-1 from
lpr-0.43-2. I had experienced no problems with the previous
version, however when I upgraded and tried to print from the
remote machine to the print server I go the error.

Oct 20 16:02:31 shamrock lpd[878]: posty:
cfA701garnet.col-ed.org: Permission denied

The other error message recieved was:
Oct 20 16:23:54 shamrock lpd[1146]: unlink
file=dfA706garnet.col-ed.org, ret=-1, errno=13

These are examples cut from shamrock's syslog.

I was able to get the printer to work, but had to manually
do 'chmod o+rw' to the queue files in /var/spool/lpd/posty/

The permissions on /var/spool are:
rwx------   3 daemon   daemon       1024 Aug 16 13:35 at
drwx------   2 root     root         1024 Sep 10 13:03 cron
drwxrwxr-x   3 root     daemon       1024 Oct 19 18:12 lpd
drwxrwxr-x   2 root     mail         1024 Oct 20 04:02 mail
drwxr-xr-x   2 root     mail         1024 Oct 20 16:50
mqueue

The permissions on /var/spool/lpd are:
-rw-r--r--   1 root     root            5 Oct 20 16:53
lpd.lock
drwxr-xr-x   2 root     lp           1024 Oct 20 16:51 posty

The permissions on /var/spool/lpd/posty are:
-rwxr-xr-x   1 root     root         9443 Jun 21 16:55
filter
-rwxr-xr-x   1 root     root          191 Jun 21 16:55
general.cfg
-rw-r--r--   1 root     root            5 Oct 20 16:53 lock
-rwxr-xr-x   1 root     root          348 Jun 21 16:55
postscript.cfg
-rw-rw-r--   1 root     root           28 Oct 20 16:50
status
-rwxr-xr-x   1 root     root          148 Jun 21 16:55
textonly.cfg

One machine is running RH 6.0 the other (shamrock) is
running 6.1. Both machines are running kernel 2.2.13.

If there is any other information you need. Please let me
know.

sincerely yours,

Christiopher Martinsen
Comment 1 Bill Nottingham 1999-10-21 15:57:59 EDT
Once you've done this, does it now print normally, or does it
continue to fail?
Comment 2 Bill Nottingham 1999-10-29 16:53:59 EDT
This was fixed in the 0.46 errata, correct?
Comment 3 chris 1999-10-29 16:57:59 EDT
Yes, the problem was resolved with version 0.46 of the lpr package.
Comment 4 Zdenek Drlik 2000-01-05 02:15:59 EST
I have the same problem with 0.46-1. I can print from RedHat 6.1 to redHat 6.0
print server, but when I try to cancel the job, I get "permission denied".
(on pc55.net1.kb):
lpr -Prlp1 adresy.html
lprm -Prlp1 1
linux.net1.kb(print server): cfA001pc55.net1.kb: Permission denied

I have the same problem to print from HPUX 10.20, from which I need to print to
Linux print server with RedHat 6.0 and lpr-0.46. Printing works fine, but
canceling the job don't work (the same perm.denied as from RH).

Note You need to log in before you can comment on or make changes to this bug.