Bug 616946 - php exits prematurely when calling phpinfo() with php-pecl-imagick installed
Summary: php exits prematurely when calling phpinfo() with php-pecl-imagick installed
Status: CLOSED DUPLICATE of bug 559675
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pecl-imagick   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-21 19:42 UTC by Radu Alexandru Popescu
Modified: 2010-07-22 12:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 12:17:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Radu Alexandru Popescu 2010-07-21 19:42:46 UTC
Description of problem:
Extension makes php exit prematurely.
Package outdated. Current stable version is 3.0.0 ( http://pecl.php.net/package/imagick )

Version-Release number of selected component (if applicable):
2.2.2-4.fc12

How reproducible:
Always.

Steps to Reproduce:
1. Install php-pecl-imagick on an up-to-date (as of today) install.
2. Make a file containing "<?php phpinfo(); ?>"
3. Request the file in httpd.
  
Actual results:
Incomplete phpinfo page and an error in /var/log/httpd/error_log
"httpd: magick/semaphore.c:525: LockSemaphoreInfo: Assertion `semaphore_info != (SemaphoreInfo *) ((void *)0)' failed.".

Expected results:
Normal phpinfo page and no error in /var/log/httpd/error_log.

Additional info:
I reported the error for x86_64 but it might be on other platforms. If additional information or testing is required please let me know.

Comment 1 Pavel Alexeev 2010-07-22 12:17:41 UTC

*** This bug has been marked as a duplicate of bug 559675 ***


Note You need to log in before you can comment on or make changes to this bug.