Bug 61695 - (NFS IRIX)NFS files from IRIX server missing
Summary: (NFS IRIX)NFS files from IRIX server missing
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-23 00:27 UTC by Daniel E. Shipton
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 10:58:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the 2.4.18 patch for it....from the (3.12 KB, patch)
2002-03-23 00:28 UTC, Daniel E. Shipton
no flags Details | Diff

Description Daniel E. Shipton 2002-03-23 00:27:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020212

Description of problem:
All kernels that read from an IRIX server for nfs will not list all files in
directories that are mounted and also will not list all of the directories that
are really there.  But if you know they exist you can go there. We get this alot
and our developers build scripts don't work when it is causing a problem.  This
is very fixable.  the fix is located at http://www.fys.uio.no/~trondmy/src .  it
is the seekdir patch.  When I compile my kernel with that patch everything works
fine.  I have tested it on 2.4.9 and 2.4.18 and they both will apply...with
2.4.18 you have to change paths in the diff.  It would be helpful if you
included this patch in an update and also in rawhide.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mount irix filesystem
2.look through directories for files and directories that are missing
3. if you didn't find any missing its cause you weren't on the irix machine also
looking to see what your missing :)
	

Additional info:

Comment 1 Daniel E. Shipton 2002-03-23 00:28:37 UTC
Created attachment 49784 [details]
the 2.4.18 patch for it....from the

Comment 2 Arjan van de Ven 2002-03-23 10:47:03 UTC
Guess what. this patch is already in the 2.4.9 kernels RH ships

Comment 3 Daniel E. Shipton 2002-03-25 04:32:19 UTC
Guess what. rawhide 2.4.17 also had the patch i evidently. I am just looking for
uniformity. 2.4.17 is on one of our servers and if i could get that one i would
use it....but 2.4.18 is out there without the much need patch.

Comment 4 Daniel E. Shipton 2002-03-25 21:50:15 UTC
ohh.....must be missing an additional patch or something because the groups are
not translating right execpt for the 2.4.9 you mentioned

Comment 5 Daniel E. Shipton 2002-03-27 17:21:48 UTC
tried the new rawhide 2.4.18-0.8 with no luck.

Comment 6 Daniel E. Shipton 2002-03-27 20:52:10 UTC
ok..2.4.17 that i thought was working also has this bug.  THIS IS RIDICULOUS.
the upgrade kernel 2.4.9 is the only one that seems to work.

2.4.17 .18-0.4 .18-0.8
cd /home6/users
ls | grep dshipton



2.4.9
cd /home6/users
ls | grep dshipton
dshipton

just my example how i can tell....
this is a real problem for us.

Comment 7 Steve Dickson 2004-08-11 10:58:23 UTC
This turns out to be a IRIX bug that was fixed.


Note You need to log in before you can comment on or make changes to this bug.