Bug 61700 - bad calculation of space requirements during install
bad calculation of space requirements during install
Status: CLOSED DUPLICATE of bug 60695
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-03-23 00:10 EST by greg hosler
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-23 00:10:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description greg hosler 2002-03-23 00:10:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.9-13smp-MO i686; Nav)

Description of problem:
2 problems here.

I did a custom install, with a /usr of 2.5 gb

I selected a goodly amount of packages for installation. Knew it would be close,
thought I was ok. (I DO have a /usr/src partition for the kernel sources).

at the begining of installation, it told me that /usr was short by 19 mb.
ok, fine, I backed up to the package selection, deleted a few packages, maybe 30
or 50 mb worth, and continued forward. This time I get the message:

	/ needs -1968056K

(that's the 1st problem)

I hit "ok", and the installation went forward without further ado, or
The install completed ok, and I noted at the end that there was 189mb available
after install. I _know_ I did not remove ~200 kb worth of packages (the 19 it
was short, plus the 189 mb I ended up with...)

(the 2nd problem is that the original calculation of the about of space needed
off by about 10%, OR it did not take into consideration /usr/src)

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1. set up /usr as 2.5 gb
2. select individual packages
3. select most individual packages, amounting to close to 2600k
get the error about /usr not big enough, backup remove some packages, then
go forward.

Expected Results:  no way that the / should be computed as *MINUS* 1968056K

Additional info:
Comment 1 Jeremy Katz 2002-03-24 01:32:52 EST

*** This bug has been marked as a duplicate of 60695 ***

Note You need to log in before you can comment on or make changes to this bug.