Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 617006 - [abrt] yum-3.2.27-12.el6: progress.py:271:_do_update:IOError: [Errno 5] Input/output error
[abrt] yum-3.2.27-12.el6: progress.py:271:_do_update:IOError: [Errno 5] Input...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-urlgrabber (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
BaseOS QE - Apps
abrt_hash:5d56ceff
: RHELNAK
Depends On: 539567
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-21 17:38 EDT by Ben Woodard
Modified: 2014-01-21 01:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-14 11:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.33 KB, text/plain)
2010-07-21 17:38 EDT, Ben Woodard
no flags Details

  None (edit)
Description Ben Woodard 2010-07-21 17:38:51 EDT
abrt version: 1.1.10
architecture: x86_64
component: yum
executable: /usr/bin/yum
kernel: 2.6.32-42.el6.x86_64
package: yum-3.2.27-12.el6
reason: progress.py:271:_do_update:IOError: [Errno 5] Input/output error
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
time: 1279547173
uid: 0

backtrace
-----
progress.py:271:_do_update:IOError: [Errno 5] Input/output error

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/urlgrabber/grabber.py", line 1585, in _progress_update
    self.opts.progress_obj.update(downloaded)
  File "/usr/share/yum-cli/output.py", line 68, in update
    TextMeter.update(self, amount_read, now)
  File "/usr/lib/python2.6/site-packages/urlgrabber/progress.py", line 141, in update
    self._do_update(amount_read, now)
  File "/usr/lib/python2.6/site-packages/urlgrabber/progress.py", line 271, in _do_update
    self.fo.flush()
IOError: [Errno 5] Input/output error

Local variables in innermost frame:
ui_time: '     07:02'
text: '(63/156): kernel-debuginfo-2.6.32-44.1.el6.x86_64.rpm'
fread: '130 M'
ui_rate: ' 174 kB/s'
blen: 21
ui_size: ' | 130 MB'
out: '(63/156): kernel-debuginfo-2.6. (52%) 64% [=============-       ] 174 kB/s | 130 MB     07:02 ETA \r'
self: <output.YumTextMeter instance at 0x22eb170>
ui_bar: ' [=============-       ]'
etime: 570.5795841217041
tl: <urlgrabber.progress.TerminalLine instance at 0x35a5d40>
ui_pc: ' 64%'
frtime: '07:02'
amount_read: 136759840.0
frac: 0.64557982832390304
sofar_size: 338782092.0
now: 1279546639.91469
ui_sofar_pc: ' (52%)'
rtime: 422.01860511811299
bar: '=============-'
fetime: '09:30'
ave_dl: '174 k'
sofar_pc: 52.434641871533515
ui_end: ' ETA '

How to reproduce
-----
1. was doing an update when this happened.
2.
3.
Comment 1 Ben Woodard 2010-07-21 17:38:53 EDT
Created attachment 433521 [details]
File: backtrace
Comment 3 RHEL Product and Program Management 2010-07-21 17:58:06 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 RHEL Product and Program Management 2011-01-07 10:54:37 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Phil Knirsch 2011-06-09 10:07:42 EDT
Is that still an issue?

Thanks & regards, Phil
Comment 6 Ben Woodard 2011-06-09 12:44:02 EDT
haven't seen it in a while.
Comment 7 Phil Knirsch 2011-06-14 11:05:31 EDT
Thanks Ben.

We haven't seen it anywhere else, so i'm closing this as worksforme for now. Should you see it again please feel free to reopen and let us know how to reproduce.

Thanks & regards, Phil

Note You need to log in before you can comment on or make changes to this bug.