Bug 617066 - [ml_IN] buttons at the bottom of software update screen is getting cut for Malayalam when resolution is lower (using vesa driver)
Summary: [ml_IN] buttons at the bottom of software update screen is getting cut for Ma...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Martin Minar
URL:
Whiteboard:
Keywords: RHELNAK, Translation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-22 06:25 UTC by Praveen Arimbrathodiyil
Modified: 2016-07-04 00:55 UTC (History)
12 users (show)

Fixed In Version: firstboot-1.110.7-1 rhn-client-tools-1.0.0-46.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 13:04:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing buttons getting cut (2.30 MB, image/jpeg)
2010-07-22 06:25 UTC, Praveen Arimbrathodiyil
no flags Details
screenshot showing buttons not getting cut (malayalam) (267.93 KB, image/png)
2010-08-10 07:31 UTC, Ankit Patel
no flags Details
Screen shot of firstboot (83.30 KB, application/x-troff-man)
2010-08-19 03:07 UTC, Kenichi Takemura
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0565 normal SHIPPED_LIVE rhn-client-tools and yum-rhn-plugin bug fix and ehnancement update 2011-05-18 17:57:10 UTC

Description Praveen Arimbrathodiyil 2010-07-22 06:25:14 UTC
Created attachment 433589 [details]
screenshot showing buttons getting cut

Description of problem:

Buttons to accept or reject Red Hat Network configuration is getting cut at the bottom (screenshot attached)

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. use vesa driver for installation (xdriver=vesa nomodeset)
2. check if resolution is smaller
3. proceed to firstboot
  
Actual results:

buttons are getting cut when there is enough space to resize the message to fit the screen

Expected results:

proper display of buttons

Additional info:

Comment 2 RHEL Product and Program Management 2010-07-22 06:57:52 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 David Cantrell 2010-07-22 14:05:26 UTC
This is a problem with the translation information for the language you are using.  It is too large, causing the window to grow beyond the screen size.  Filing a translation request via localization-services@redhat.com.  Closing this bug since the translators track their issues via a different system.

Comment 5 Ankit Patel 2010-08-10 07:31:26 UTC
Created attachment 437788 [details]
screenshot showing buttons not getting cut (malayalam)

Please check this, it's working fine with firstboot-1.110.7-1.el6.

Comment 7 Kenichi Takemura 2010-08-19 03:06:32 UTC
I used virt-install to verify this bug.

Seems still to exist.

Can you help me to check?

Comment 8 Kenichi Takemura 2010-08-19 03:07:12 UTC
Created attachment 439569 [details]
Screen shot of firstboot

Comment 9 Martin Banas 2010-08-24 12:46:15 UTC
I can see the same error as Kenichi Takemura, resolution 800x600. Moving back to assigned

Comment 10 Denise Dumas 2010-08-24 13:24:07 UTC
Moving to 6.1, does not meet blocker criteria

Comment 11 Ankit Patel 2010-09-01 11:36:49 UTC
Hi Ani,

Is it possible to shorten the translations shown in the attachment #433589 [details] ?

Thanks!
Ankit

Comment 12 RHEL Product and Program Management 2010-11-16 00:49:29 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 13 Martin Gracik 2010-11-18 13:56:04 UTC
This module comes from rhn-client-tools, it implements that dialog window in question, so I'm changing the component to rhn-client-tools.

Comment 14 Ankit Patel 2010-12-10 12:47:47 UTC
Ani ping.

Comment 15 Ani Peter 2010-12-17 07:29:29 UTC
All,
Have shortend the translations and committed upstream and downstream:

https://translate.fedoraproject.org/projects/p/spacewalk/c/rhn-client-tools/raw/client/rhel/rhn-client-tools/po/ml.po

However the issue is not fixed yet. On testing I noticed that its working well on normal resolution. But on this particular resolution what happens is, for Malayalam, the messages on the screen like in screenshot appears in four lines. Whereas in all other languages it works well and fits correctly in two lines.

Comment 16 Ankit Patel 2010-12-17 09:19:09 UTC
Thanks Ani.

I have checked languages other Malayalam too and found similar issue exist with almost all of them. It's not a translation problem that we can solve. It has something to do with the width of the text appears in the dialog box that appears on the screen.

Requesting developers and/or i18n engineers to look at it.

Thanks,
Ankit

Comment 17 Miroslav Suchý 2011-01-19 13:50:58 UTC
Note to myself. In locale en_US has this window size 468x434. In ml_IN it has size 586x640.
Therefore if you have screen height 600px (probably some netbook) you are unable to reach those buttons.

Comment 18 Miroslav Suchý 2011-01-19 15:17:20 UTC
If I replace
<property name="width_chars">-1</property>
with:
<property name="width_request">600</property>
resp.
<property name="width_request">460</property>

make the size of window 646 x 470 (ml_IN) resp. 646 x 427 (en_US).

So it gain more on width (where is enought space) and lost on height.

Comment 19 Miroslav Suchý 2011-01-19 15:32:17 UTC
commited to spacewalk.git as commit 62fdbf568bfcf3bf7ad646d4aa52987ba30cd05d
cherry picked to satellite.git as commit 2ca7e13c93616acfceeb3a5840c3db21cb5f2073

Comment 21 Martin Minar 2011-02-18 12:53:40 UTC
Resolution reduce verified in rhn-setup-1.0.0-48.el6.noarch.

Comment 22 errata-xmlrpc 2011-05-19 13:04:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0565.html


Note You need to log in before you can comment on or make changes to this bug.