Bug 617090 - luci cannot create a rhel6 cluster when "Enable shared storage" or "Download Packages" is selected
Summary: luci cannot create a rhel6 cluster when "Enable shared storage" or "Download ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
: 577170 695572 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-22 07:20 UTC by Fabio Massimo Di Nitto
Modified: 2011-04-12 03:19 UTC (History)
6 users (show)

Fixed In Version: ricci-0.16.2-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 22:17:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes names of packages and init scripts to prevent ricci failure (1.61 KB, patch)
2010-07-22 21:21 UTC, Chris Feist
no flags Details | Diff

Description Fabio Massimo Di Nitto 2010-07-22 07:20:59 UTC
Andrew and I finally isolated the issue to this check.

If Enable storage is not selected, the cluster is created just fine.

I can´t see anything in the logs that tells why it fails with shared storage.

Comment 1 Chris Feist 2010-07-22 21:21:01 UTC
Created attachment 433812 [details]
Fixes names of packages and init scripts to prevent ricci failure

This is caused by several issues within ricci.

Packages are hardcoded inside of ricci and the RHEL6 ricci is using the RHEL5 packages and init scripts.

I've attached a patch that I have tested will fix this problem.

Comment 2 Chris Feist 2010-07-27 21:26:46 UTC
Created cluster with luci and updated ricci packages and everything works.  Moving to modified.

Comment 5 releng-rhel@redhat.com 2010-11-10 22:17:13 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Comment 6 Chris Feist 2010-12-01 06:45:45 UTC
*** Bug 577170 has been marked as a duplicate of this bug. ***

Comment 7 Ryan McCabe 2011-04-12 03:19:58 UTC
*** Bug 695572 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.