Bug 617148 - Hide Menu Subsys->Config changes from users without view configure rights
Hide Menu Subsys->Config changes from users without view configure rights
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
3.0.0
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2010-07-22 06:40 EDT by Heiko W. Rupp
Modified: 2014-06-08 18:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-08 18:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2010-07-22 06:40:18 EDT
If a user has no "show configuration" rights, the Subsystems->Configuration menu + tab
should be greyed out, same for tabs on the individual resource.
Comment 1 Charles Crouch 2010-07-22 09:29:07 EDT
This is something which should be addressed in the UI enhancements
Comment 5 Jay Shaughnessy 2011-02-14 12:29:37 EST
If I understand this I think the problem is resolved. if not please supply repro steps.
Comment 6 Sunil Kondkar 2011-06-21 05:21:14 EDT
Tested on build 149 (Version: 4.1.0-SNAPSHOT Build Number: 04f721e)

Created a resource group of datasources, created a user.
Created a role without Configure Read/Write resource permissions.
Assigned the group of datasources and the user to the role.

Logged in as the user and navigated to 'Reports->Subsystems' and observed that the 'Configuration History' menu is not greyed out. User can click on the 'Configuration History' menu.

It does not display any config changes to the user.

Steps to reproduce:
1. Create a Compatible group of resources (Ex: RHQ Agent or datasources)
2. Create u user (testuser)
3. Create a role without Configure Read/Write resource permissions. (testrole)
4. While creating the role, assign the compatible group of RHQ Agents and the user 'testuser' to the role.
5. Log in as testuser.
6. Navigate to 'Reports->Subsystems'.
7. The 'Configuration History' menu is not greyed out. User can click on the 'Configuration History' menu.

Additional Notes:

For the user without Configure Read/Write resource permissions, the resource's configuration tab and the group configuration tab is greyed out. Also the resource/group context menu option 'Resource Configuration' is greyed out.

Note You need to log in before you can comment on or make changes to this bug.