Bug 61717 - wrong frequency displayed in radio application
Summary: wrong frequency displayed in radio application
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: xawtv (Show other bugs)
(Show other bugs)
Version: phoebe
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-23 14:33 UTC by David Balažic
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-06 16:27:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for 0.00 frequency bug (899 bytes, patch)
2003-01-20 18:42 UTC, David Balažic
no flags Details | Diff
Do a range check on entered frequency (493 bytes, patch)
2003-01-20 18:45 UTC, David Balažic
no flags Details | Diff

Description David Balažic 2002-03-23 14:33:31 UTC
Description of Problem:

When the "radio" application is started, it displays the frequency 00.0, while 
the hardware is actually playing a valid radio channel. When I press the cursor-
up key, the displayed frequency increases( 00.0, 00.1 , 00.2 ... ). Also the 
tuned frequency of the radio hardware increases. If I press cursor-down, then 
both the displayed and played frequency are reset to 108.00 and continue to 
decrease from that value ( 108.0 , 107.9 , 107.8 ... )

Version-Release number of selected component (if applicable):

xawtv-3.72-1 on a Hampton beta2 system

How Reproducible:

always

Steps to Reproduce:
1. start /usr/bin/radio
2. push cursor-up
3. 

Actual Results:

Displayed frequency is 00.0, whil tuning the frequency goes 00.1, 00.2 ...

Expected Results:

The frequency to which the hardware is tuned should be displayed. While tuning, 
then really used frequency should be displayed.

Additional Information:

Comment 1 David Balažic 2002-03-27 09:26:06 UTC
I also noticed that the program accepts almost any frequency.
( with the 'g' key )
If I enter 133, it accepts it. Pressing cursor-down will descrease the value :
133 , 132.95 , 132.90 , 132.85 .... this is WRONG
Pressing cursor-up will reset the value to 87.50, which is OK.

Also if anything lower than 87.50 is entered, like 85 it is accepted.
Pressing cursor-up will increase that value :
85.00 , 85.05 , 85.10 , 85.15 .... this is WRONG
Pressing cursor-down will reset the value to 108.00, which is OK.


Comment 2 Ngo Than 2002-03-27 14:10:06 UTC
It's not a bug, please read the manual page of tuner.

Comment 3 David Balažic 2002-03-29 08:57:43 UTC
Which manual page is that ?
$man tuner # does not find anything
the man for "radio" doesn't say anything about this.

Besides 133MHz obviously wrong. If it is an OK value the why is it reset to 
87.5 when I press crsr-up ? Why doesn't it go back to 133.00 when I press crsr-
down again ?

Comment 4 David Balažic 2002-04-10 15:19:39 UTC
When using out of range frequencies ( like 122 MHz ) then the kernel printks 
messages like :
tuner: radio freq (121.93) out of range (65-108)

So if there is not bug, what is the valid range of frequencies ?

Comment 5 David Balažic 2002-11-19 20:55:30 UTC
Bug still there in redhat linux 8.0 , xawtv-3.74-4

Comment 6 David Balažic 2003-01-14 17:56:40 UTC
Still here in xawtv-3.81-2

Comment 7 David Balažic 2003-01-20 18:42:26 UTC
Created attachment 89441 [details]
Fix for 0.00 frequency bug

This fixes the problem when after start the displayed frequency is 0.00MHz

Comment 8 David Balažic 2003-01-20 18:45:59 UTC
Created attachment 89442 [details]
Do a range check on entered frequency

This fixes the problem that the user can enter any ( invalid ) frequency

Comment 9 David Balažic 2003-02-04 16:25:08 UTC
These patches are included with xawtv-3.83, please upgrade the redhat package 
to that version.
Or should I post a separate RFE for that ?

Comment 10 Ngo Than 2003-03-06 16:27:17 UTC
i have added it in 3.85-1. thanks for your patch file.


Note You need to log in before you can comment on or make changes to this bug.