Bug 617225 - "import pygsl" causes segmentation fault
"import pygsl" causes segmentation fault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pygsl (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-22 10:20 EDT by Ling Li
Modified: 2011-03-23 18:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: pygsl-0.9.5-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-23 18:57:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ling Li 2010-07-22 10:20:10 EDT
Description of problem:
Importing pygsl in python gives segmentation fault.

Version-Release number of selected component (if applicable):
pygsl-0.9.5-1.fc13.i686 and gsl-1.13-2.fc13.i686

How reproducible:
I only have one FC13 system in a VMware environment.  It was always reproducible in that system.

Steps to Reproduce:
python -c 'import pygsl'
  
Actual results:
Segmentation fault

Additional info:
It seems that pygsl.init wasn't able to load.

I installed the newer build, pygsl-0.9.5-2.fc14.i686 and gsl-1.14-1.fc14.i686 from rawhide, and the problem is gone.  Not sure if the problem was with gsl or pygsl.
Comment 1 Ling Li 2010-08-15 23:48:43 EDT
hmm, rawhide now moves to Python 2.7, and the trick to use the rawhide pygsl doesn't work any more (otherwise yum will try to replace all the python packages).  Is it possible to issue an update to Fedora 13?  Thanks.
Comment 2 José Matos 2010-08-25 14:23:01 EDT
You are right, it crashes for me as well as soon as I import pygsl, the backtrace I get is:

(gdb) bt
#0  0x0000000000000000 in ?? ()
#1  0x00007ffff0bfe54f in initinit () from /usr/lib64/python2.6/site-packages/pygsl/init.so

I suspect that the problem is with pygsl.

Recompiling the rpm is enough to make the problem go away.

Right now I am trapped inside a proxy so I can't fix the problem. I will do it as soon as possible.

Thanks for the report.
Comment 3 Ling Li 2010-10-30 11:42:42 EDT
Nice.  Could you recompile the rpm for both x86_64 and i686?  Thanks.
Comment 4 Fedora Update System 2011-03-15 12:09:59 EDT
pygsl-0.9.5-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/pygsl-0.9.5-2.fc13
Comment 5 José Matos 2011-03-15 12:12:20 EDT
Oops, it looks like I forgot this report. My bad. :-(

I have built a new version for Fedora 13,
https://koji.fedoraproject.org/koji/taskinfo?taskID=2913956

and I have request a push to updates.

Thank you for the report.
Comment 6 Fedora Update System 2011-03-23 18:57:08 EDT
pygsl-0.9.5-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.